KDE apps slow to load on new installation

I just installed Manjaro KDE yesterday and everything is going great, except one particular problem. All the KDE apps start horribly slow. Dolphin, Konsole, the Settings Manager, almost all KDE apps start slow (Dolphin often takes 15-20 seconds to start and Konsole takes 5-7 seconds). Once started, everthing runs smooth. All other apps start pretty fast. I've tried most solutions I could find (tweaking compositor settings, changing QT_GRAPHICSSYSTEM to raster etc.) and nothing has worked so far.

When the apps start, the window is transparent, if I move the window, it moves showing whatever was in the back previously (like taking a snapshot).

28 posts were split to a new topic: KDE apps slow to load trimmed posts

Sounds like you need an SSD drive. Please post your specs:

inxi -Fxxxz
1 Like

@tbg I do have an SSD although my /home is mounted on an HDD. The SSD is used as root. Here's the output of inxi -Fxxxz:

System: Host: sintan-pc Kernel: 5.1.1-2-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0
Desktop: KDE Plasma 5.15.5 tk: Qt 5.12.3 info: latte-dock wm: kwin_x11 dm: SDDM
Distro: Manjaro Linux
Machine: Type: Laptop System: HP product: HP Pavilion Laptop 14-bf1xx v: Type1ProductConfigId
serial: Chassis: type: 10 serial:
Mobo: HP model: 83CE v: 59.38 serial: UEFI: Insyde v: F.31 date: 10/30/2017
Battery: ID-1: BAT1 charge: 38.9 Wh condition: 38.9/42.1 Wh (92%) volts: 12.6/11.6
model: Hewlett-Packard PABAS0241231 type: Li-ion serial: status: Discharging
CPU: Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake rev: A
L2 cache: 8192 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31880
Speed: 726 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 700 2: 698 3: 700 4: 700 5: 700 6: 700
7: 700 8: 740
Graphics: Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:5917
Device-2: NVIDIA GM108M [GeForce 940MX] driver: N/A bus ID: 01:00.0 chip ID: 10de:134d
Display: x11 server: X.Org 1.20.4 driver: intel compositor: kwin_x11 resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.0.4 compat-v: 3.0
direct render: Yes
Audio: Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
bus ID: 00:1f.3 chip ID: 8086:9d71
Sound Server: ALSA v: k5.1.1-2-MANJARO
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard
driver: r8168 v: 8.047.01-NAPI port: 3000 bus ID: 02:00.0 chip ID: 10ec:8168
IF: eno1 state: down mac:
Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: 3000 bus ID: 03:00.0
chip ID: 8086:095a
IF: wlo1 state: up mac:
Drives: Local Storage: total: 1.03 TiB used: 508.49 GiB (48.4%)
ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB speed: 6.0 Gb/s
rotation: 5400 rpm serial: rev: RSM7 scheme: GPT
ID-2: /dev/sdb vendor: SanDisk model: SD8SN8U-128G-1006 size: 119.24 GiB speed: 6.0 Gb/s
serial: rev: 0006 scheme: GPT
Partition: ID-1: / size: 108.63 GiB used: 13.12 GiB (12.1%) fs: ext4 dev: /dev/sdb5
ID-2: /home size: 902.60 GiB used: 495.36 GiB (54.9%) fs: ext4 dev: /dev/sda3
ID-3: swap-1 size: 8.10 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb3
Sensors: System Temperatures: cpu: 46.5 C mobo: 29.8 C
Fan Speeds (RPM): N/A
Info: Processes: 293 Uptime: 8m Memory: 7.71 GiB used: 1.61 GiB (20.8%) Init: systemd v: 242 Compilers:
gcc: 8.3.0 Shell: bash v: 5.0.7 running in: konsole inxi: 3.0.34

I don't know if it's just placebo but my pc just woke up form hibernation and it seems way snappier.

You shouldn't need to use preload with an SSD and a computer that new. I would think something is not quite right with your setup. My computer is 10 years old and I've never needed preload with KDE on Manjaro. You shouldn't need it with your system if things are working properly.

1 Like

@tbg Seems logical. How can I go about finding what's wrong though?

@tbg I've tried disabling baloo before. Didn't make any difference. What worked is preload. Also, it seems better after waking up from hibernate (even better than a fresh boot). I don't understand this at all.

Well that's what preload does. It gives you faster startup times on your programs by caching them, but it shouldn't be required on modern hardware.

1 Like

Well, I only know it hasn't been used by recent installs by default as it was felt it was no longer needed. I'm not saying it doesn't serve a purpose, it just shouldn't be required on a normal install on modern hardware.

He shouldn't be experiencing those delay times. Preload obviously helps with that, but it shouldn't be happening in the first place is all I'm saying.

2 Likes

Before you go all full out changinging your video stup install htop. It is a terminal app, start it in terminal.

What is your cpu usage like and what are the things at the top of the list for using resources.

1 Like

Personally I would not put your home on the platter drive. That negates half the benefit of having an SSD IMO. Have your home partition on the SSD and symlink your large storage folders such as Video into your home directory.

4 Likes

But that never caused problem in any other distro. All of them were debian based though.

How fast is the drive and is it internal.

It is internal. What do you mean by how fast? I've achieved speeds over 100 Mbps while copying from an external drive (also HDD).

Is it a platter drive 7200rpm. SSD is still way faster.

1 Like

That's to be expected. I meant it's not too slow.

Anyway, to those who faced a similar problem, I solved the problem by moving /home to my SSD and symlinking big folders from my HDD. Thanks to @tbg for helping me out.

1 Like

Forum kindly sponsored by