KDE Aplications launcher, widgets, favorites constant flickering or reloading

I have installed manjaro with KDE 2 days ago, I have 3 problems with KDE and I think they are related to each other, but I can’t find any information about it.
Some areas suffer a re load
For example, applications constantly show “Applications updated” and it does not allow me to choose any applications.
Likewise, when trying to add a widget, it also flashes constantly.
And finally in the favortios menu, if under the page, the second it returns to the top.
I use an external mouse, I have thought that the problem could be something out there, I have disconnected it but the problems persist, I have tried to recreate the menu with “kbuildsycoca5 --noincremental” and restart, but the problem persists.
I am attaching a video to better show the problem.
Any idea how to fix it???


I have exact the same issue. I thought that my old system settings are corrupted after many updates. So i did fresh install and after few minutes it start again. System is very laggy. My KDE Desktop is 5.20 and the latest version of Manjaro. In have recorded all problems. youtu.be/0MFNFPrLPq0

I am experiencing the same exact problem here. I just installed Manjaro this past weekend. Glad (but not really) to see someone else having the problem because I was going crazy trying to figure out what I did to cause it.

Unfortunately I have no idea what the problem is or how to fix it.

I also cannot add panels probably due to the same bug. When I right-click on the desktop or another panel, the “add panel” submenu disappears. And it disappears after the same amount of time that the “flickering” occurs on the application menu and widget selector.

update: Dolphin has also stopped working reliably. And the whole system is running slowly. All CPU cores at 50% for no apparent reason. My poor DE is falling apart before my eyes!

update2: I checked out htop and ksysguard. Plasmashell was using 50% cpu and 4gb of memory! After restarting the computer, I started htop and ksysguard again. Things started off semi-normal with CPU use overall around 10%. Over a few minutes (did nothing but literally watch) plasmashell started using up more cpu and memory.

Memory usage by plasmashell started around 300k, slowly increased to 500k and eventually reached 1.3GB. I tried to add a widget and the memory useage dropped down to 200k. After getting rid of the widget menu, the memory useage continued to climb again. CPU usage by plasma floated around 40-50% the whole time. The system frequently and unexpectedly crashes as well: complete free-up, can’t even get to a tty.

This whole situation is bizzare. I’m in the process of backing up important data so I can reinstall this weekend. If it happens again, i’ll be going back to Debian where all the software is old and stable like me.

update3: Maybe this might be useful information. I opened a terminal, dropped down to a tty, killed plasmashell and krunner since they were running amok. Restarted plasmashell from the terminal. When I tried to add a widget, this popped up in the terminal:

file:///usr/lib/qt/qml/org/kde/plasma/components/ModelContextMenu.qml:38:1: QML ModelContextMenu: Accessible must be at
tached to an Item
file:///usr/lib/qt/qml/org/kde/plasma/components/ModelContextMenu.qml:38:1: QML ModelContextMenu: Accessible must be at
tached to an Item
TODO: port listCategories()
file:///usr/lib/qt/qml/org/kde/plasma/extras/PlasmoidHeading.qml:68: ReferenceError: plasmoid is not defined

I also had the same issue after many updates. So I restored my system with Timeshift, and avoided the issue by not updating the package “kservice-git (5.77.0.r831.g1cc298b-1)”. I updated all system packages except kservice-git, and there seems no issue.

A couple other threads seem to be describing the same problem. I can’t post links yet, so the name of the thread I’m referring to is: “Manjaro KDE critical bug: Plasmashell extreme CPU usage + IO write (also affecting lattedock, dolphin, krunner)” Apparently it is a bug with KSycoca. What wound up fixing the issue for me was just moving one particular file:

mv ~/.config/mimeapps.list ~/.local/share/

Good luck.

1 Like

Hi guys,

This is my first post on a linux platform ever. I only do it, coz I was startled about the beauty of manjaor and kde.

Same problem here. Just installed manjaro plasma kde on a virgin partition. Everything went well, installed about a dozen apps from the official repo. Rebooted and everything goes beserk. The language - locale problem still exists, bluetooth devices are no more recognized and kde acts weird. There must be a major problem since I did not make any updates from the pamac-manager concerning the os. I changed the global design and plasma style, but this should be possible.

I don’t have an excessive usage resources though. I also played around with timeshift, but I think the problem lies deeper than that.

The kservice didn’t work on my setup. I tried to downgrade it and I was no more able to start kde.

Somebody must have missed the test routine while deploying this version of manjaro and kde.

This work for me, but need make this time to time…

Same problem. Some of my apps are flickering and the whole log-in screen is doing that while I am typing the password and I am experiencing some random hangs and crashes.

Seems like all of our problems are due to a problem with an earlier build of 20.2 Nibia. The simplest, most straightforward solution is to download the latest build image and reinstall (that’s what I’m going to do). See the PSA: KDE edition came partly with git-packages section of this post:

There is a script there which can remove the git packages and replace them with stable repository versions. This is a very unlucky thing to have happen right when I’m trying Manjaro for the first time.

1 Like

I solved the problem with installing Manjaro 20.1 and then updating it over the update manager to 20.2. The price for this is a new installation and downloading of 1.5 GB.
But it solved all my problems, which brings me to the conclusion that 20.2 is still too buggy. This is 4 days ago, so there might have been already made some upgrades on the ISO.

I have the same problem on my new workstation. Surprisingly, this does help. I have only Postman and Slack entries there.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.