KDE Animation lags

Update: Even with free drivers it works slow.

Please post the hardware here!

okay i will currently i am updating the system i just did a fresh install few hours ago. Btw what the command for listing the hardware info ?.

inxi -Fz

and/or

lspci -v

System:
  Host: pc Kernel: 4.19.45-1-MANJARO x86_64 bits: 64 
  Desktop: KDE Plasma 5.15.5 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: Gigabyte model: GA-78LMT-S2 serial: <filter> 
  BIOS: Award v: F5 date: 10/19/2012 
CPU:
  Topology: Quad Core model: AMD FX-4300 bits: 64 type: MCP 
  L2 cache: 2048 KiB 
  Speed: 1404 MHz min/max: 1400/3800 MHz Core speeds (MHz): 1: 1396 
  2: 1405 3: 1406 4: 1402 
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1070] driver: nvidia v: 418.74 
  Display: x11 server: X.Org 1.20.4 driver: nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 418.74 
Audio:
  Device-1: AMD SBx00 Azalia driver: snd_hda_intel 
  Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel 
  Device-3: Creative Labs CA0106/CA0111 [SB Live!/Audigy/X-Fi Series] 
  driver: snd_ca0106 
  Sound Server: ALSA v: k4.19.45-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 2.27 TiB used: 7.66 GiB (0.3%) 
  ID-1: /dev/sda vendor: Western Digital model: WD20EZRX-22D8PB0 
  size: 1.82 TiB 
  ID-2: /dev/sdb vendor: Hitachi model: HDS5C1050CLA382 size: 465.76 GiB 
Partition:
  ID-1: / size: 257.87 GiB used: 7.66 GiB (3.0%) fs: ext4 dev: /dev/sda7 
Sensors:
  System Temperatures: cpu: 27.8 C mobo: N/A gpu: nvidia temp: 48 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 185 Uptime: 3m Memory: 11.72 GiB used: 769.0 MiB (6.4%) 
  Shell: bash inxi: 3.0.34

I havent install the non-free drivers yet.

Install them via terminal or Manjaro graphical settings tool, then do this:

Should i use auto install propitiatory drivers button from hardware configuration tab ?

Yeah, that's what I meant

i see so manjaro releases their own version of the drivers. I what hoping that they will 1 version behind.

i used the auto button, heres the output.

Starting

> Skipping already installed config 'video-nvidia' for device: 0000:01:00.0 (0300:10de:1b81) Display controller nVidia Corporation GP104 [GeForce GTX 1070]

is this okay should i go through rest of the guide ?

I cant follow you clearly.

Sorry, just saw the output you posted above. You have the driver installed and running already. This driver is up to date and works perfectly. Follow the steps and use google or ask if something isn't clear.

nvidia-settings from terminal would allow you to set the OpenGL parameters.

$ nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"

/etc/X11/mhwd.d/nvidia.conf

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceFullCompositionPipeline=On}"

But before you do anything else, install kwin-lowlatency from AUR.

Should i run this command in terminal i already disabled nvidia-settings >OpenGL settings >Sync to Vblank. Compositor > Tearing Prevention (Vsync) = Never.
In compositor my Redering backend is set to OpenGL2.0 there is an option for OpenGL 3.1 should i use that ? or leave it as it is ?. I am using Kernel 4.19.45-1 everything is default. And how do i check my kwin version ?
nevermind that was kwin not kwin latency

just include the line

Option "metamodes" "nvidia-auto-select +0+0 {ForceFullCompositionPipeline=On}"
in /etc/X11/mhwd.d/nvidia.conf

section Screen as shown above.

As to kwin-latency, you need to install an AUR helper first. For example trizen or yay and then install the package with:

pacman - S yay

yay -S kwin-lowlatency

after it compiles, it will say it's conflicting with kwin and will ask whether you want to replace it y/N. Say y > Enter, reboot and you're good to go.

Is it okay if i install with Trizen ? i installed it via Octopi ill install kwin-low latency using octopi

yeah, perfect. Same drill.

@GeorgeB, I've just tried kwin-lowlatency out of curiosity.
I don't notice any difference at all here on a first glance.
Just wondering why some people are affected but not others.

But thanks for the tip, it might help a lot of people. Good advice!

Thanks, I did extensive testing over the weekend, especially on Sunday. Best overall performance you can squeeze out in the current situation (with the above settings). Kwin-lowlatency's creator had modded the code for nvidia gpus as seen on his github page. I don't think compositing has ever run as smooth, even with the old Triple buffering legacy solution on previous Plasma releases.

It solves buffering issues in games, hardware accelerated video too, stutters. It's a game changer and it deserves much more recognition. Hence, I'm posting left and right for people to see and use it. This is the best way to get it fixed in future KDE releases. Keep the project alive and share the word. Hopefully KDE devs would take notice.

I will. And I'll try some games too, because the plain desktop doesn't show improvements here (guess I'm part of the lucky ones...), but they might be more noticeable in games and/or videos.