kde 18.0.4 cannot boot from live usb

i tried installing manjaro from a bootable usb
I managed to get to this screen
however when i clicked boot i got this screen
i have booted in both uefi, secure boot is disabled and i have tried both usb 2.0 and 3.0 ports and i don't know what else could be causing this. i'm trying to dual boot windows and manjaro

my hardware is as follows
CPU: AMD Ryzen 5 3600X 6-Core Processor
GPU: AMD Radeon RX 5700 XT
Motherboard: X470 GAMING PLUS

You have a very new GPU.

Try the latest RC iso's, they should work.

if your talking about the latest manjaro iso i believe 18.0.4 is the latest for kde? should i try a different version?

try the 18.1 rc version:

it contains the fixed systemd

2 Likes

Not sure how long this is suppose to take but i have been on this screen for 20 minutes now

It does that with both free and nonfree drivers?

Yes its the same with both free and non free

CTRL + ALT + F3

and login as root. Try to find out what the issue might be. Either use systemctl to see which service might have an issue or try to start with startx. mhwd -lh might list your hardware.

For the first command everything is active, plugged, mounted, excited, or running

is there a way i can export these logs?

BTW, how do I go from rc5 to rc7?

I've got all updates (-Syyu), but Manjaro Hello still shows rc5.

Operating System: Manjaro Linux
KDE Plasma Version: 5.16.4
KDE Frameworks Version: 5.60.0
Qt Version: 5.13.0
Kernel Version: 5.2.5-2-MANJARO
OS Type: 64-bit