Kcm_translations.so is missing / System Settings / Regional Settings / Language page is not working

On the Regional Settings page, only Language page is not working on Plasma, all other pages work such as Formats, Spell Check and Date & Time.

Is this a bug?

My systems is:
Operating System: Manjaro Linux
KDE Plasma Version: 5.24.6
KDE Frameworks Version: 5.96.0
Qt Version: 5.15.5
Kernel Version: 5.18.12-3-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-9700 CPU @ 3.00GHz
Memory: 31.2 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630

libpackagekitqt5.so.1 is owned by packagekit-qt5 package.
kcm_translations.so is owned by plasma-workspace package.

Either partial update or you did not reboot the system after update.

sudo pacman-mirros -f5 && sudo pacman -Syyu packagekit packagekit-qt5 plasma-workspace

Actually not. Some dependency definition is missing, so packagekit-qt5 never gets pulled… Maybe plasma-workspace should depend on packagekit-qt5?

PS: Sorry for answering an slightly old thread, but a moment ago other user asked in a Telegram group about it and I noticed that I had the same issue. Although I solved it I was a bit curious if others had noticed this before.

1 Like

packagekit-qt5 is optional for plasma-desktop and frameworkintegration.
Based on the latest KDE description brand that can be read here Repositioning the KDE Brand | KDE.news

The order of importance and subsequent dependencies is Workspace < Desktop < Packagekit

I see your point, but in practice a user without technical knowledge just see an error and have no clue how to solve it. That it’s just what I’m saying.

Isn’t the forum for such situations? :slightly_smiling_face:

so, how did you fix it?
I notice the same thing on my system.

The thing is, when I update, I never reboot, I only shutdown, then turn on.
I had no idea that the Reboot is more important.

@bogdancovaciu already mentioned which packages contain those files, so you can deduce from that what you need.

But in general if some file (usually a library) is missing you can always update file database (so you have latest info) and (regex) search to which package it belongs:

sudo pacman -Fy
pacman -Fx libwhatever.so

If you have just the same error, then the solution is to install the packagekit-qt5 package

Thanks, I fixed it. :grinning: