Kann Abhängigkeiten nicht erfüllen


#1
[dennis@ux310 ~]$ sudo pacman -Syu 
[sudo] Passwort für dennis: 
:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Installation vontcl (8.6.9-2) verletzt Abhängigkeit 'tcl=8.6.8', benötigt von tclx
[dennis@ux310 ~]$

#2

Bei AUR Paketen kann es manchmal nötig sein diese vor einem Update zu entfernen. Dann das Update durchzuführen und dann die AUR Pakete wieder zu installieren.

In deinem Fall müsstest du tclx entfernen. Das Update durchführen und dann tclx neu gegen tcl Version 8.6.8 bauen.