Just cannot get Manjaro running (infinite boot loop)

Hey everyone,
I was using Kubuntu on an old Laptop and liked it so far. But now I have a new desktop PC and wanted to give Manjaro a shot because I only heard positive things about it and it doesn’t come with Snap which is completely useless. (researched for hours why my Opera needed 30 seconds to start. Solution: don’t use the snap version)
Anyway, I tried to install Manjaro and chose the option to encrypt the entire disk. Installation was quick but after restart I couldn’t get past the encryption password prompt. Googled for hours and finally found out that Manjaro let’s you choose your keyboard layout during installation but the password prompt just uses the US-layout. Little tiny hint would have been useful.
Now I can type in the password and Manjaro starts to boot but stays in booting loop forever (Manjaro logo and moving dots).
I already tried to use the USB live system to fix it. Booted into it, mounted the encrypted disk which worked fine and I could access it but
sudo manjaro-chroot -a
just tells me that it cannot find any Linux distros.
Fast boot is turned off, secure boot is turned off. As you may have already noticed I’m quite frustrated at this point. I really appreciate the work all of you guys put into this and I really don’t wanna spread hate but all I want is to use this fu**ing distro! :smile:
Do I need a doctor’s degree to set this up? Am I just stupid or is Manjaro allergic to new users?
Can maybe anyone help this whiny little noob?
Thx in advance :v:

Just throwing this out, when you start to boot Hold down the F7 or maybe it’s F8 and then you get the screen with the list of kernels to run.
You could enten E and that brings up the grub.cfg file and you could look for the ‘linux’ line the the
quiet splash options.

Arrow down to the line and arrow over those option and delete them, temporary of course, and then continue to boot by pressing F10 or ctrll-x
then it will list out the entire boot process and maybe, just maybe you can see where it hangs.
am I way off base here?

I came here from Kubuntu because I didn’t like snap. Since you can get the usb to boot, maybe try again. Maybe try it without the encrypted drive?

Did you partition your setup in /boot /root /home (and /swap)?
In this case it’s good enough to encrypt your /home partition only, which is recommended in many Linux discussions.

Thank you guys!
I actually tried to follow @herbie’s advice but changing the grub.cfg file didn’t change anything and no additional information was displayed during boot. Then I just had the random idea of connecting only one monitor via HDMI and disconnect the other display port monitor. That did the trick. Don’t ask me why :smiley: