Just another case of `Waiting for 1 module` in installer

Booted from DVD and from USB, no matter what I do, when I start the installer I get the same loading message before the system freezes minutes later. I-m using the gnome edition. Have internal 1 SSD and 1 mechanical disks. i7 notebook processor. nvidia graphic card (670mx). No matter if I boot with free or propietary drivers.

I changed all settings in BIOS, with no results.

I looked on the forums for this problem and I found a lot of posts, every one with different solutions, one of them was changing from IDE to AHCI in BIOS, but my setting was already to AHCI (I changed to IDE just in case, but didn-t solve the problem)
As cleverly states this user, this is a too common problem,
(I can-t put links because I-m new)
And while I`m writing this post is clear that guy is right:
(I can-t upload screenshot because I-m new, but at my right the forum is sugessting me that my post is very similar to other topics with almost the same title, which I already visited and they were all closed with different or even no solutions, all on different desktops xfce, plasma, and now my gnome)

I-ll add more details:

When I booted from DVD, when I start the installer, the disc starts reading as mad, and never stops, I also note that the loading animation seems to restart every few seconds (it make a jump appearing suddenly few pixels above and then positioning again on a lower position, until it happens again few seconds later.

These small details makes me guess that whatever is trying to load, it restarts again every few seconds. Hope it helps.

If anyone tells me how to send a log of the installer I-ll post here.

More details

I updated the Live system (1.7GB of updates), now, when I open installation program works after 30 seconds of loading.

BUT, when I arrive to disk partitioning screen, it keeps loading for some seconds and then the graphical interface restarts, closing all programs and having to start installation again.

(btw, the Known problems link of the installer doesn-t work -it does nothing-)

Hello @Kano3D :wink:

Start the Setup with:

sudo calamares --debug

on the terminal. Then post the terminal output here formatted as code. Thanks.

I-m putting some of the lines:

16:29:04 [6]: void Calamares::RequirementsChecker::reportProgress()
    Remaining modules: 1 
16:29:05 [6]: void Calamares::RequirementsChecker::reportProgress()
    Remaining modules: 1 
16:29:07 [6]: void Calamares::RequirementsChecker::reportProgress()
    Remaining modules: 1 
16:29:08 [6]: void Calamares::RequirementsChecker::reportProgress()
    Remaining modules: 1 

ok… well… please run this:

sudo parted -l

and post the output.

   ~  sudo parted -l                                                   ✔ 
Model: ATA LITEONIT LAT-256 (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type     File system  Flags
 1      1049kB  213GB  213GB   primary  ntfs
 4      213GB   255GB  41.7GB  primary  jfs          boot
 2      255GB   256GB  1042MB  primary  ntfs         msftres
 3      256GB   256GB  472MB   primary  ntfs         msftres

Model: ATA Hitachi HTS72757 (scsi)
Disk /dev/sdb: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type     File system  Flags
 1      1049kB  375GB  375GB   primary  ntfs         boot
 2      375GB   439GB  64.3GB  primary  ntfs
 3      439GB   750GB  311GB   primary  ext4

Model:  USB  SanDisk 3.2Gen1 (scsi)
Disk /dev/sdc: 30.8GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      3800MB  3804MB  4194kB  primary               esp

When pasting terminal output, add three backticks ` OR 3 tilde ~ above and below the text:


I did it this time for you. Please do it like this in the future.

Thank you :bowing_man:

1 Like

I want to install on sdb3, already formatted in ext4

Did you boot in EFI or BIOS (legacy mode)?

test -d /sys/firmware/efi/efivars/ && echo "efi" || echo "bios"

That command say EFI, and I think my system doesn-t allow legacy mode

Then you cannot install it like that. All your disks are MS-DOS, which means → BIOS/Legacy. EFI generally needs GPT to start with. Then it needs an EFI partition. Normally, you can choose the mode on the “BIOS Bootloader”. Normally there are 2 entries with the same USB disk with different modes.

I needed to switch to legacy USB so the Manjaro USB were detected. Then appeared as EFI USB, It is related?

Just note that I previously installed Debian on that partition, with the same BIOS/UEFI settings than now

Something like that:

Your Boot Menu can look different.

But already appeared as EFI USB on the BIOS

Dude, all your Disks are Installed in BIOS Legacy mode, therefore you need to boot in BIOS mode to install it.

You can boot in EFI mode, but when you install it then, you have recreate partition table as GPT, not MS-DOS. That means wipe a full disk. Plus you will not be able to boot Windows with grub.

Then I should boot from DVD, because in legacy mode USB is not detected for booting from it

Anyway, that doesn-t explain why the entire graphical interface restarts when I-m in the partitioning screen

Well that must be investigated. Anyway… it has to do with your partitions, since you mentioned the partition module.


Is this really a JFS file system? Or is it NTFS? That could be a blocker here.