Jenkins

jenkins

#1

Hello.
I am trying to set up jenkins on raspberry but I have some problems with it.

[manjaro@manjaro-arm ~]$ sudo systemctl status jenkins
● jenkins.service - Extendable continuous integration server
   Loaded: loaded (/usr/lib/systemd/system/jenkins.service; disabled; vendor preset: disabled)
   Active: active (running) since Thu 2018-11-22 17:22:42 CET; 4min 33s ago
 Main PID: 29823 (sh)
    Tasks: 9 (limit: 999)
   Memory: 32.1M
   CGroup: /system.slice/jenkins.service
           ├─29823 /bin/sh -c eval $JENKINS_COMMAND_LINE
           └─29824 /usr/bin/java -Xmx512m -jar /usr/share/java/jenkins/jenkins.war --webroot=/var/cache/jenkins --http>

Nov 22 17:22:42 manjaro-arm systemd[1]: Started Extendable continuous integration server.
Nov 22 17:22:59 manjaro-arm jenkins[29823]: Running from: /usr/share/java/jenkins/jenkins.war
Nov 22 17:24:40 manjaro-arm jenkins[29823]: Nov 22, 2018 5:24:39 PM org.eclipse.jetty.util.log.Log initialized
Nov 22 17:24:40 manjaro-arm jenkins[29823]: INFO: Logging initialized @116954ms to org.eclipse.jetty.util.log.JavaUtil>
Nov 22 17:24:42 manjaro-arm jenkins[29823]: Nov 22, 2018 5:24:42 PM winstone.Logger logInternal
Nov 22 17:24:42 manjaro-arm jenkins[29823]: INFO: Beginning extraction from war file
[manjaro@manjaro-arm ~]$ sudo systemctl status jenkins
● jenkins.service - Extendable continuous integration server
   Loaded: loaded (/usr/lib/systemd/system/jenkins.service; disabled; vendor preset: disabled)
   Active: active (running) since Thu 2018-11-22 17:22:42 CET; 4min 52s ago
 Main PID: 29823 (sh)
    Tasks: 9 (limit: 999)
   Memory: 32.6M
   CGroup: /system.slice/jenkins.service
           ├─29823 /bin/sh -c eval $JENKINS_COMMAND_LINE
           └─29824 /usr/bin/java -Xmx512m -jar /usr/share/java/jenkins/jenkins.war --webroot=/var/cache/jenkins --httpPort=8090 --ajp13Port=-1

Nov 22 17:22:42 manjaro-arm systemd[1]: Started Extendable continuous integration server.
Nov 22 17:22:59 manjaro-arm jenkins[29823]: Running from: /usr/share/java/jenkins/jenkins.war
Nov 22 17:24:40 manjaro-arm jenkins[29823]: Nov 22, 2018 5:24:39 PM org.eclipse.jetty.util.log.Log initialized
Nov 22 17:24:40 manjaro-arm jenkins[29823]: INFO: Logging initialized @116954ms to org.eclipse.jetty.util.log.JavaUtilLog
Nov 22 17:24:42 manjaro-arm jenkins[29823]: Nov 22, 2018 5:24:42 PM winstone.Logger logInternal
Nov 22 17:24:42 manjaro-arm jenkins[29823]: INFO: Beginning extraction from war file

so it seems that jenkins is working fine but when I try to access web interface to configure it at http://192.168.1.6:8090/ (which is rapsberry ip address) or using elinks on rpi http://localhost:8090/ I get connection error and that’s it. Where can I find jenkins log files so I could take a look at it? Or maybe I am missing something (some other service for example) that must be enable so I could access jenkins web page?

Best regards.


#2
  1. Put the log in code format </>
  2. Check your firewall settings and make sure port 8090 is open on your server.

#3

This is fresh manjaro installation so no firewall rules whatsoever

sudo iptables -L
[sudo] password for manjaro:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

#4

What Java version are you using?


#5
$ java -version
openjdk version "1.8.0_171"
OpenJDK Runtime Environment (build 1.8.0_171-b10)
OpenJDK 64-Bit Zero VM (build 25.171-b10, interpreted mode)


#6

Please check if your java environment is version 8.

archlinux-java status


#7
$ archlinux-java status
Available Java environments:
  java-8-openjdk/jre (default)

#8

I’m out of ideas then. Seemed pretty simple back when I installed it a couple of years back.


#9

It isn’t that important I’ll run jenkins on my desktop instead but it is very strange, I’ve found this command to list all open ports on local machine and it seems that jenkins is listening but for some reason connection is impossible

$ sudo netstat -tulpn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:5355            0.0.0.0:*               LISTEN      326/systemd-resolve
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      351/sshd
tcp6       0      0 :::5355                 :::*                    LISTEN      326/systemd-resolve
tcp6       0      0 :::22                   :::*                    LISTEN      351/sshd
tcp6       0      0 :::8090                 :::*                    LISTEN      29824/java
udp        0      0 0.0.0.0:5355            0.0.0.0:*                           326/systemd-resolve
udp        0      0 127.0.0.53:53           0.0.0.0:*                           326/systemd-resolve
udp        0      0 192.168.1.6:68          0.0.0.0:*                           292/systemd-network
udp        0      0 0.0.0.0:68              0.0.0.0:*                           348/dhcpcd
udp6       0      0 :::5353                 :::*                                29824/java
udp6       0      0 :::5355                 :::*                                326/systemd-resolve
udp6       0      0 :::33848                :::*                                29824/java


#10

I have only run jenkins slaves on the rpi’s. Never the entire thing.


#11

Do not ask me how it happened but it worked or maybe performance is so terrible that jenkins started 30 minutes after it was run.


#12

jenkins is pretty ressource heavy, so yeah. Maybe it just needed some time.