IWD (with Eduroam) fails to get IP address

Hi all. First time user here. I have a Pinebook Pro and it works great at home, however for some reason it won’t connect to my school’s WiFi (eduroam).

I am using Sway so I went vanilla with my networking setup. Iwd + systemd-networkd + eduroam.8021x file.

It connects to eduroam but doesn’t grab an address.

Journalctl tells me a few things for for iwd:

CMD_CONNECT Succeeded, but parsing FTE failed. Expect handshake failure
EAP completed with eapFail
4-Way handshake failed for ifindex: 2, reason: 23
1_dhcp_client_stop: 1247 Entering state: DHCP_STATE_INIT

I couldn’t find any info on what FTE is with my Google-foo.

Edit: Before anyone asks I’m using the built in DHCP server with IWD. My main.conf file has:

I would suggest trying the default networking stack, which (as far as I can tell even in the Sway edition) is NetworkManager rather than systemd-networkd and wpa_supplicant rather than iwd. The NetworkManager stack reliably connects to Eduroam in my experience (both on my x86_64 notebook and on my PinePhone). Though the Eduroam configuration can also vary to some extent from institution to institution, and there might also be a hardware or driver issue. But I would at least try the default stack if I were you, if only to know whether it is the networking stack’s fault or something else’s (hardware, driver, or the access point on the other end).

I’m not using iwd but wpa_supplicant in combination with systemd-networkd for eduroam, so I could help there.

At least there is a wiki entry for iwd and eduroam which might help: iwd - ArchWiki

I read elsewhere that wpa_supplicant worked in a similar situation. I will try it sometime soon and update everybody. It’s not a big emergency, I can still get work done on campus without my laptop having wifi.