It seems `Alt` has been mapped to `Esc` in konsole

I recently found that I cannot use <M-]> keymap in NeoVim.

In insert mode, when I type <M-]>, it will be mapped to ] in normal mode, so it seems that Alt has been mapped to Esc in konsole. How can I disable this mapping?

Depending on what is actually causing the descrepency between the current settings and your desire …
Check your profie settings.
Settings > Edit Current Profile > Keyboad Tab

The following is all keymappings related with Alt:

But it seems that it does not specify such mapping.