Issues with XFCE GUIs after update

Other friends with the update reported no issues with the GUI other than some oversized elements; however I am having some issues after the latest update.

If anyone has any advice, I’d appreciate it. Thank you.


You mentioned and tagged XFCE, you show screenshots with KDE Plasma stuff and then another screenshot with the Gnome dash/dock and also mentioned it … so, i guess you are deep into chimeras.

What are you using to deal with Qt widget style? Start your investigation from there and set it properly.

1 Like

I’m sorry I’m not really big with the inner workings of the GUI, I’m a long time Windows user with some Ubuntu administration knowledge so I’m sure you can see how I would get confused on all of the components.

I don’t quite understand.

I would not explain it better than this Uniform look for Qt and GTK applications - ArchWiki


Sorry for the late reply. I’ve had a look at your link and I’m not sure other than I haven’t really been messing with the Qt themes since I’m not picky, but I’m pretty sure I’m using Adwaita.

I have also tried messing with the settings after installing kde-gtk-config but to no avail.
I haven’t changed any theme settings before the update and it just kind of messed up on it’s own, every Qt GUI has this visual glitch. Is there any way to return things back to normal?

I would also not mind having to completely reset all of my themes/settings to do this.

Again I apologise for my lack of expertise :sweat_smile:

That works under KDE Plasma as requires kdecoration

If you did not replaced manjaro-xfce-settings then you can copy all the files in /etc/skel/ to your home directory while you are logged out, and once you log in it would all be as was intended by default.

I just did that while logged out (outside of the GUI) as well, to repeat I have ran cp -r /etc/skel/. /home/<username>/ and after logging in, the issue still persists. I am quite perplexed as to why this would suddenly be happening with Qt.

Right … Does that happen in a TEST user too, if you create one?

I haven’t actually thought of trying that. But it doesn’t happen on a newly made test account. I’m not sure what’s happening with my main account then. Good to hear it’s not a system-wise issue.

Your user has mixed stuff. You can use Qt5ct to set the engine to Kvantum and then from Kvantum to set the theme you want.

Give us:

ls -l /usr/share/xsessions

It was already set to Kvantum.

total 24
-rw-r--r-- 1 root root 7885 Jul 12 23:01 gnome-classic.desktop
-rw-r--r-- 1 root root 7829 Apr 28 12:09 gnome.desktop
-rw-r--r-- 1 root root 7914 Apr 28 12:09 gnome-xorg.desktop

Guess was good.

This is a FrankenGnome with some KDE stuff, maybe some Xfce…

Best thing will be to do a fresh install with the one and only wished DE.

Mixing DEs always ends in scroubouldista. No one can escape Scroubouldistan.

1 Like

So basically my issue is that I’m running multiple GUI interfaces at once? I’m still puzzled as to why this happened but I can’t wait to be only running one of them.

Well, from commands outcome you seem to run only gnome, but from your issues, you seem to try to use other DE’s tools.
Not clear.
The sane handling is to have one and only DE and only to use it’s tools.

If you want to use a toll that depends on another DE, rather install it with flatpak : it’ll use DE specifics in a kind of container, thus not fiddling with your DE.

I see. How would I go about disabling those tools?