Issues with QGeeM USB 3.0 adapter

I apologize for the non-specific title, but…

initially Manjaro just got stuck during boot sometimes if the USB hub was plugged in.

Now, for a week+ (presumably after an update) I’ve been getting what I thought were network issues, where my connection would drop and then take several minutes to re-establish… the browser becoming partially unresponsive in the mean time (some buttons worked, some had no effect)
Then I was doing some troubleshooting and found the same thing would happen in non-internet applications… the file browser taking a good minute to make a new folder… grinding to a halt trying to make another. Problems seemingly happening faster with each boot.

Remove the USB hub and I can boot and run normally.
I only had my keyboard and mouse on the hub, no internet or storage devices, but I need it to free up ports on my laptop.

The hub is a QGeeM USB 3.0 adapter
Laptop is MSI GS75 10SE-1028CA
Manjaro 21.2.1
Kernel: Linux 5.10.89-1-MANJARO
KDE Plasma Version: 5.23.4

I’m only a semi-competent linux-er… please tell the commands needed to get any diagnostic info you ask for.

mod. edited impertinent title

Hi @Canid, and welcome!

At first glance, that sounds like a hardware problem. Which could be anything hardware-related. From the hub itself, too the cable to connect it. Best would be to replace it completely, especially if it has a critical function.

However, you can try finding the error by analyzing the logs:

  • To view all log entries for the current boot, i a terminal, run:
sudo journalctl
  • To view all log entries of the previous boot, run:
sudo journalctl --boot=-1 
  • To view al errors and critical log entries for the previous boot, run:
sudo journalctl --boot=-1 --priority=3
  • To view all error and critical log entries of the current boot, run:
sudo journalctl --priority=3
  • To view all USB related error and critical log entries from the previous boot, run:
sudo journallctl --boot=-1 --priority=3 | grep --ignore-case usb

For more information:

Hope this helps!

1 Like

It’s just a USB dongle to add ports, and it’s not connecting anything sensitive, but it doesn’t give me any problems if I boot into windows. I don’t think there’s anything wrong with the dongle, some piece of software just doesn’t like it.

There are actually no USB errors in the logs for any of the boots today (now yesterday)… first USB error is from two days ago

   ~  sudo journalctl --boot=-1 --priority=3 | grep --ignore-case usb                                                                                                                                          ✔ 
    ~  sudo journalctl --boot=-2 --priority=3 | grep --ignore-case usb                                                                                                                                      0|1 ✘ 
    ~  sudo journalctl --boot=-3 --priority=3 | grep --ignore-case usb                                                                                                                                      0|1 ✘ 
    ~  sudo journalctl --boot=-4 --priority=3 | grep --ignore-case usb                                                                                                                                      0|1 ✘ 
Jan 12 12:41:28 HEGGE kernel: PM: dpm_run_callback(): usb_dev_resume+0x0/0x10 returns -5
Jan 12 12:41:28 HEGGE kernel: usb 1-5.3.2: PM: failed to resume async: error -5

Forgive me for stating the obvious, but have you tried with a different kernel? Please see [HowTo] Provide System Information and, if applicable, [HowTo] post screenshots and links.

I was on either Kernel 5.14.21-2 or 5.15.12-1 (I forget which) and downgraded it to the current one, which didn’t help. Should I try rolling it back further? I am pretty sure the kernel wasn’t updated when the problems got worse.

There is no “current one”. Manjaro has multiple kernels.

Try 5.10 or 5.4, both of which are LTS (Long Term Support) and see if it works better and keep one that works best:

Open a terminal and run:

mhwd-kernel --install linux54

To install kernel version 5.4 or:

mhwd-kernel --install linux510

to install version 5.10.

Reboot when done, and just after the UEFI screen prompting you to Press a button to enter setup…, tap the Esc key repeatedly until the GRUB screen appears.

On the grub screen, navigate to Advanced… and enter it by pressing . On the subsequent screen, select the kernel you just installed, and press Enter to use it.

Test if it works better, and which one it is, if it does.

maybe not linux-related, but sometimes computers get stuck at booting if the option to enable booting from external devices is enabled in the Bios. it’s worth to check your bios and if it’s enabled to disable this option and test again. i had a similar problem with an hama-multicard-reader. if this one is plugged in and the option to enable booting from external devices the pc get’s stuck because it wants to boot from this.

“Current one” meaning the one I am running now, listed in my first post: Kernel: Linux 5.10.89-1-MANJARO

Both the one I was initially on, and 5.10 had the problem, and it went from only boot problems to much worse without a change of kernel.

The boot problem was happening after the grub menu>manjaro selection. In any case I could deal with that - current issue makes the system unusable while running.