Issues with KMS


On my new laptop, I’ve been trying to install Manjaro. When using modesetting and thus the ‘xf86-video-intel’ driver, the screen appears like this:

Only half the of the screen is usable. When using the ‘nomodeset’ flag, this issue goes away. I want to use the hardware acceleration though, so for me, this is no good. Any ideas?


Have you tried the modesetting Xorg video driver?

As far as I know, the xf86-video-intel driver does not use mode-setting. The video-modesetting driver however does.

Just to clarify, video mode-setting has nothing to do with acceleration. It is simply the difference between the kernel managing the switching between different video modes and letting the display server ─ e.g. X.Org ─ take care of it. With mode-setting enabled, the kernel handles the switching between different video modes, which (in theory) should be a little faster and cleaner.

Yes, I know this. The key here is that the driver that supports proper acceleration requires modesetting. The framebuffer driver does not support acceleration.

‘xf86-video-intel’ requires modesetting according to this page: Intel graphics - ArchWiki

Same issue there unfortunately.

Does not make sense.
Those are 2 different things.

That page says no such thing…

Note: Some (Debian & Ubuntu, Fedora, KDE) recommend not installing the xf86-video-intel driver, and instead falling back on the modesetting driver for Gen4 and newer GPUs

Right here. The driver is not the progidal modesetting driver, however it is a driver that uses kernel modesetting. Requires it, in fact.

That’s the in-kernel i915 driver, not the driver for X.Org.

Back to meaning “KMS” (kernel mode setting)
as opposed to the modesetting driver.

…so …

what is it you are trying to do ?
Did you try to set up early KMS, or did you just install xf86-video-intel and now things look weird? or ? …

Lets also be clear about how things are handled with drivers in manjaro … you need to use mhwd or the GUI frontend ‘manjaro settings manager’.

This will provide profiles like:
video-linux = default open drivers
video-modesetting = will make sure an intel gpu uses modesetting and not xf86-video-intel

It seems to me there is some misunderstanding … please get your grub and boot and everything back to normal … most likely start by ensuring you are up to date, have a good working kernel, and reinstall video-linux

sudo mhwd -f -i pci video-linux

And then we can go from there…

How to provide good information

EDIT - oops … I realize this is before install?
The live image?
What ISO are you using exactly ?

So, I actually didn’t do anything. Simply booting the installer, in fact, any Linux installer. All of them. Including CLI installers. All have this issue with only have the screen showing.

I will fully reinstall MANJARO by booting the installer with the “nomodeset” and get back to you in a few moments.

What ISO are you using ?

Cinnamon. I’ve also tried KDE and Architect. Very similar results.

I mean specifically … give me links or numbers or something :wink:

Ah. Well, this is the filename ‘manjaro-cinnamon-20.2-201208-linux59.iso’. Just downloaded it about 20 minutes ago.

I am extremely hesitant to pin this on the ISO. I’ve tried half a dozen linux distributions. They all do this. Don’t think I’ve been getting that many screwed up ISOs…

If its a very new laptop, and it does this on other distros too … I have a feeling it might need the newest of things?

For some reason it looks like Architect is still using a 5.6 kernel.
And the ones you just got are 5.9 [EOL].

Hm … might be a tricky machine/timing.

Whats the model? Or preferably can you print an inxi ?

Here is that output for you:

CPU: 6-Core Intel Core i7-10750H (-MT MCP-) speed/min/max: 900/800/5000 MHz
Kernel: 5.9.11-3-MANJARO x86_64 Up: 1m Mem: 742.4/15778.6 MiB (4.7%)
Storage: 823.74 GiB (0.8% used) Procs: 346 Shell: Bash inxi: 3.1.08

It’s an HP Envy 15T.

Ah … can you try param


(I know it shouldnt affect some half-displayed screen thing exactly … but quirks be quirks)

Unfortunately, that didn’t work. I’ve also just squinted my way through installing it, so I can try updating the kernel?

Ah if you managed that then yes … try kernel and try difference between older i915 and modesetting