Issues with connecting to Wifi at my Community College

Hi, I’m very new to Manjaro, and this is the first Linux distro I’ve really enjoyed, something weird is going on with how the wifi works though. I had no problems connecting to my work wifi and my home wifi, but the problem stemmed from my School’s wifi. I did a log of what was causing the issue when it first happened and tried to show it to one of the IT folks on site but they didn’t know anything about Arch and probably nothing about Linux. So I made an account here to ask for some help as a new guy.

heres the dump that I got when I put the “net” out for the issue.

[Aug22 08:30] audit: type=1111 audit(1661175036.035:100): pid=339 uid=0 auid=4294967295 ses=4294967295 msg='op=connection-add-activate pid=633 uid=1000 result=fail exe="/usr/bin/NetworkManager" hostname=? addr=? terminal=? res=failed'

Also I’ve seen a lot of stuff about issues with my particular Network Controller its an RTL8821CE

When I tried to connect it said something about “Does not support PSK but the setting requires it” My work uses PSK so I don’t think its an issue on my side, so I guess it could be a problem on the IT folk’s side, but then again I don’t know I’m pretty new to this stuff. :stuck_out_tongue:

I’d like to thank y’all for your time. Sorry for the rambly mess.

provide system info, and what kernels you have installed:
inxi -Faz
mhwd-kernel -li

for “inxi -Faz”

System:
  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=cf9917e1-8106-40fc-9525-3e3db45254cb rw quiet
    udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Convertible System: HP product: HP Pavilion x360 Convertible
    15-dq0xxx v: Type1ProductConfigId serial: <superuser required> Chassis:
    type: 31 serial: <superuser required>
  Mobo: HP model: 85C8 v: 34.23 serial: <superuser required> UEFI: Insyde
    v: F.11 date: 09/04/2020
Battery:
  ID-1: BAT0 charge: 39.8 Wh (100.0%) condition: 39.8/39.8 Wh (100.0%)
    volts: 12.9 min: 11.6 model: 333-42-5C-A HT03041XL type: Li-ion
    serial: <filter> status: discharging
  Device-1: hid-0018:04F3:23CA.0002-battery model: ELAN2514:00 04F3:23CA
    serial: N/A charge: N/A status: N/A
CPU:
  Info: model: Intel Core i5-8265U bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check gen: core 8 built: 2018
    process: Intel 14nm family: 6 model-id: 0x8E (142) stepping: 0xC (12)
    microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 903 high: 1494 min/max: 400/3900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 740 2: 817 3: 1494
    4: 1294 5: 744 6: 700 7: 737 8: 700 bogomips: 28808
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620]
    vendor: Hewlett-Packard driver: i915 v: kernel arch: Gen-9.5
    process: Intel 14nm built: 2016-20 ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:3ea0 class-ID: 0300
  Device-2: Lite-On HP Wide Vision HD Camera type: USB driver: uvcvideo
    bus-ID: 1-4:2 chip-ID: 04ca:709d class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: BOE Display 0x076e built: 2017 res: 1366x768
    hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1366x768
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa
    22.1.6 direct render: Yes
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:9dc8 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw_8821ce v: N/A
    modules: rtw88_8821ce,8821ce pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:c821 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  IF-ID-1: bnep0 state: unknown speed: N/A duplex: N/A mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8
    bus-ID: 1-10:3 chip-ID: 0bda:b00a class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: 4060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A
    class-ID: 0104
Drives:
  Local Storage: total: 476.94 GiB used: 13.57 GiB (2.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8H
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: HPS0
    temp: 25.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%) used: 13.57 GiB
    (2.9%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB
    (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 37.0 C pch: 31.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 242 Uptime: 3m wakeups: 8 Memory: 7.5 GiB used: 1.71 GiB (22.8%)
  Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.1.1 clang: 14.0.6 Packages: pacman: 1272 lib: 351 flatpak: 0
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20

and for “mhwd-kernal -li”

The following kernels are installed in your system:
   * linux515

try it with a differen kernel - you should have anyway 2 kernels installed, one main, and one backup …
install the 5.10 via comand:
sudo mhwd-kernel -i linux510
or via gui:
open system settings/kernel

then edit grub conf to be shown a grub menu during boot:
kate /etc/default/grub
and edit this line to look like this:
GRUB_TIMEOUT_STYLE=menu - its on the 3 line
save it, and update grub with:
sudo update-grub
reboot and in advanced options select the 5.10 (not the fallback one, the normal one), and test wifi with it

Okay trying this, I’m not gonna be back to school until tomorrow. So I’ll see if this Kernel version works. What should I do if this doesn’t work?

if it doesnt work with the 5.10 kernel, try changing dns in system settings/connections under ipv4 section, try quad:
9.9.9.9

if it also doesnt work install dkms drivers:
create this file with this command:
kate /etc/modprobe.d/blacklist.conf
and inside it put these lines:
blacklist rtw88_8821ce
blacklist rtw_8821ce
save the file with
install headers:
pamac install linux515-headers linux510-headers
install driver:
pamac build rtl8821ce-dkms-git
reboot and test

I’m at school right now so I can test this, but the dkms drivers didn’t work.

I also couldn’t do the 9.9.9.9 quad ipv4 thing. Problem is when I try to connect to the wifi it doesn’t actually save the info to the Network Manager. All it does is kick this to my “notifications” when I try to connect.

802-11-wireless-security key-mgmt: access point does not support psk but setting requires it

But never actually saves the actual network to my Manager. So I wouldn’t be able to do the Quad9 stuff.

I fear this might be a problem that I’d need to go to IT again and see if they can’t give the network info to me so I can manually put it in. Though I doubt they’d do that.

check these posts:

So I found out the issue was around the certificates from the IT guys. I tried the Public WiFi, I tried the Eduroam and finally on a whim after just going “Eh why not?” tried to connect to the Encrypted WiFi version and I actually got through. So that’s the answer to my problem at the moment. I appreciate your patience and work you’ve put towards this Brahma. Thanks for your time.

so if it works, you can remove the headers and the dkms drivers:

pamac remove linux515-headers linux510-headers rtl8821ce-dkms-git

then remove the config:
sudo rm /etc/modprobe.d/blacklist.conf
then reboot

A very interesting case. Did you manage to find a solution? I had a similar problem while writing an assignment. I was using my friend’s laptop and noticed that he easily formatted his paper with https://edubirdie.com/citation/chicago/ and mine was not ready at all. This helped me quickly and easily to get rid of any concerns with my paper because I was unable to set up community college Wi-Fi access.