Issues with bumblebee - cannot enable discrete graphics

Similar to the issue described here: [Bumblebee] Could not enable discrete graphics card, when I do primusrun glxgears, the following error appears:

primus: fatal: Bumblebee daemon reported: error: Could not enable discrete graphics card

systemctl status bumblebeed returns:

● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
   Active: active (running) since Wed 2019-10-09 12:11:43 EDT; 19min ago
 Main PID: 675 (bumblebeed)
    Tasks: 1 (limit: 4915)
   Memory: 2.1M
   CGroup: /system.slice/bumblebeed.service
           └─675 /usr/bin/bumblebeed --use-syslog

Oct 09 12:11:43 jqiu21-pc systemd[1]: Started Bumblebee C Daemon.
Oct 09 12:11:43 jqiu21-pc bumblebeed[675]: /usr/bin/bumblebeed 3.2.1-2017-02-27-Format:%h$ started
Oct 09 12:12:02 jqiu21-pc bumblebeed[675]: Could not enable discrete graphics card
Oct 09 12:30:07 jqiu21-pc bumblebeed[675]: Could not enable discrete graphics card

and dmesg | grep bbswitch returns:

[    3.960205] bbswitch: version 0.8
[    3.960291] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    3.960297] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[    3.960482] bbswitch: detected an Optimus _DSM function
[    3.960553] bbswitch: disabling discrete graphics
[    4.140595] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is off
[   22.906430] bbswitch: enabling discrete graphics
[ 1108.016068] bbswitch: enabling discrete graphics

After following advice found in the linked post above (modifying RUNTIME_PM_BLACKLIST and RUNTIME_PM_DRIVER_BLACKLIST in /etc/default/tlp) and rebooting, still nothing. I have also looked at advice from other posts, but nothing has worked so far.

EDIT: correcting some grammar things

Can you add inxi -Fxxxz --no-host so that other can see your hardware and system configuration?

At the moment I do not have an additional idea on your problem with bumblebee.

If you do not find any solution you can try the alternative setups to bumblebee (e.g. PRIME, optimus-manager, optimus-switch):

2 Likes

no problem:

System:
  Kernel: 4.19.69-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
  Desktop: Xfce 4.14.1 tk: Gtk 3.24.10 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: G7 7588 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0FDMYT v: A00 serial: <filter> UEFI: Dell v: 1.9.0 
  date: 02/11/2019 
Battery:
  ID-1: BAT0 charge: 41.0 Wh condition: 49.0/56.0 Wh (87%) volts: 17.1/15.2 
  model: Samsung SDI DELL W7NKD8C type: Li-ion serial: <filter> 
  status: Charging 
CPU:
  Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 53004 
  Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: N/A 
  bus ID: 01:00.0 chip ID: 10de:1c20 
  Display: x11 server: X.org 1.20.5 driver: intel unloaded: nvidia 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) 
  v: 4.5 Mesa 19.1.5 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k4.19.69-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
  v: kernel port: 5000 bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlp0s20f3 state: up mac: <filter> 
  Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Dell 
  driver: alx v: kernel port: 3000 bus ID: 3b:00.0 chip ID: 1969:e0a1 
  IF: enp59s0 state: down mac: <filter> 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:
  Local Storage: total: 238.47 GiB used: 40.62 GiB (17.0%) 
  ID-1: /dev/sda vendor: SK Hynix model: SC311 SATA 256GB size: 238.47 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: 0P10 scheme: GPT 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 5060 bus ID: 00:17.0 chip ID: 8086.282a rev: 10 
Partition:
  ID-1: / size: 122.87 GiB used: 40.55 GiB (33.0%) fs: ext4 dev: /dev/sda7 
Sensors:
  System Temperatures: cpu: 43.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 289 Uptime: 2h 37m Memory: 7.50 GiB used: 3.14 GiB (41.9%) 
  Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: bash v: 5.0.9 
  running in: xfce4-terminal inxi: 3.0.36 

I've tried nvidia prime before, to no avail. Haven't tried any of the other ones.

1 Like

Hm, I see nothing unusual in your configuration. Your graphics card should support the current drivers. Which version of the nvidia drivers have you installed? 430 is the latest recommend version according to https://www.geforce.com/drivers

Have followed this tutorial to setup prime?:


The other options are described in the FAQ Post. Optimus-switch uses a configuration like in that tutorial and switches it with a configuration for intel. However, a reboot is required for the switch.

1 Like

Hm, I see nothing unusual in your configuration.

Looking closer at it, seems like I haven't gotten a nvidia driver (Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: N/A).

Is this normal if I'm running bumblebee? If not, should I be installing video-nvidia-430xx?

Have followed this tutorial to setup prime?:

Yes. I can try again, and will probably look at optimus-switch, but would rather stay with either bumblebee, or if not possible, then go to prime.

This is normal bumblebee unloads the driver, when it's not in use. If you run optirun inxi -G you would see that the driver is loaded (if bumblebee works of course).

No, not if you want to use bumblebee. That package are the standalone nvidia drivers and are required for a PRIME setup. My question was refering to the video-hybrid-intel-nvidia-430.xx-bumblebee package.

Another point is your user in the bumblebee group? If not add it with:

sudo gpasswd -a $USER bumblebee

You then need to logout and login

1 Like

My question was refering to the video-hybrid-intel-nvidia-430.xx-bumblebee package.

I have that installed, and I have added my user to the bumblebee group.

EDIT: mhwd -li gives:

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-430xx-bumblebee            2019.08.24               false            PCI


Warning: No installed USB configs!

That looks all fine to me for a bumblebee setup.

You can check if your problem is caused by tlp by masking tlp:

sudo systemctl mask tlp

And reboot.
If it does not work, the issue is not caused by tlp. If it works, you have to find the tlp setting causing this problem.
You can enable tlp again with:

sudo systemctl unmask tlp
sudo systemctl enable tlp
1 Like

After masking, i get Created symlink /etc/systemd/system/tlp.service → /dev/null.

After rebooting, still doesn't work

This rules tlp out of causing that problem.
You can enable it again with the commands I gave you. You will have to reboot to enable tlp again.

1 Like

Can the problem be caused by a whole bunch of things being blacklisted in /etc/modprobe.d/mhwd-nvidia.conf?

blacklist nouveau
blacklist nvidia
blacklist nvidia-modeset
blacklist nvidia-uvm
blacklist ttm
blacklist drm_kms_helper
blacklist drm

I'm fairly sure that these are supposed to be blacklisted, but if you can confirm, that'd be great.

They are supposed to be blacklisted. If you are interested they are blacklisted in the post_install of the video-hybrid-intel-nvidia-430.xx-bumblebee package:

Unfortunately, I am out of ideas for the moment. :man_shrugging:

1 Like

Thanks for that. I guess I'll check out optimus-switch. The github makes it seem easy enough.

1 Like

Ok, so optimus-switch just works fine. Guess I'm using that now. Thanks

1 Like

Forum kindly sponsored by Bytemark