issues with bspwm

Greetings people!

A few days ago I did a fresh install of Manjaro-bspwm using the current Architect. I chose the "full" install as apposed to the "minimal" one. Currently I am working on configuring bspwm to meet my needs and my taste. :wink: A few things are confusing me somewhat.

  1. The panel looks kinda weird. I have not played around with the config of that yet, so I have no idea where I went wrong. When I boot the live system with bspwm it looks different (meaning: the icons are not cut off and the volume level is only there once). I'll upload a screenshot for clarification...


    What went wrong here?

  2. I am currently working through the bspwmrc. I think it's great that there is actually one to get me started! Thanks for that! What confuses me is the fact that the autostart is quite obviously also run although I see no reason why it would be. Any reference to it in the rc is commented out (which is the default) but still picom, sxkhd and some other things are started, which are only in the autostart. Where does the motivation to start that file come from? I'm currently getting some inspirations from the dotfiles from people like DT, Luke Smith etc. But all of these people don't even seem to use an autostart-file - let alone one so complex.

Thanks for helping!
Cassi

1 Like

For the cut off icons there's an issue with the glyph width for nerd-fonts-terminus, it happened on the last update to 2.1.0-1. I think it worked on the live system cause it was installed there before the update. When installed to desktop it pulled in the newer version. I've changed the "mainfont" in ~/.limepanelrc to mainfont='NotoSansMono Nerd Font:size=16:antialias=true' personally and will fix in v20 iso build. (currentlly awaiting zsh by default in v20.0.1 before updating iso)

Volume level should not be there twice, that is odd. You can try to reload bspwm with the command bspc wm -r and it will kill the panel and launch a new one to test if it is permanently this way.
Edit - Just noticed the two volume levels are different... is there multiple sound output devices?

For the second question check /usr/bin/bspwm-session.

You can autostart from numerous locations not just bspwmrc... I tend to use .xprofile (on arch) or .xsessionrc (on Debian). Here's a copy:

#!/bin/sh
#
#Shared window manager functions & applications
#	
# set compositor
#picom -b & #picom seems to have problems with hlwm 0.8.1
compton -b &

# set network manager
nm-applet &

# set sound functions
#volumeicon &
start-pulseaudio-11 &

# power related functions
xfce4-power-manager &
thermald &
tlp start &
powertop --auto-tune &
light-locker &

# xsettings
xsettingsd &
xset fp+ ~/.local/share/fonts &
# xset dpms 600 900 1200
xset r rate 350 60
xsetroot -cursor_name left_ptr &

# keyboard settings
setxkbmap -option compose:ralt &
scim -d &
ksuperkey -e 'Super_L=Alt_L|F1' &
ksuperkey -e 'Super_R=Alt_L|F1' &
	
# gnome settings
#/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 &
gnome-keyring-daemon --start --components=pkcs11 &

# shared common keybindings (applications)
sxhkd -c ~/.config/sxhkd/base.conf &

# applications
dunst -conf  ~/.config/dunst/dunstrc &
(sleep 10 && nice -n 10 dropbox start) &
redshift-gtk &
feh --randomize --bg-fill /usr/share/backgrounds/wallpapers/* &
	#/usr/bin/skypeforlinux --disable-gpu &
	#/usr/bin/skypeforlinux &
#sh -c "GDK_BACKEND=x11 pamac-tray" &

I'll be posting a significant tutorial on the topic in the next few days on my website.

1 Like

That is a really good question...

cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xec730000 irq 54
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xec080000 irq 17e code here

That seems to show me two cards. The nVidia device only gives me SPDIF, so that won't be an issue. However, there is another device, the Alsamixer lets me choose: default. This has only a "master". Device 0 gives me alle the controls in the mixer I am used to. Btw. I played around a bit with polybar and that too shows me two volume settings. Currently I am a little confused... :thinking:

Regards,
Cassi

Try running pavucontrol and see if there's anything different there.

What you're describing is the normal behavior in alsamixer, at least for me.

Also try running amixer -c 0 get Master and then amixer -c 1 get Master and posting the results.

@airclay are you the new maintainer for bspwm?
Do you know by chance if there's an active maintainer for awesome as well?
linux-aarhus has updated the iso with the newest packages to v20, but awesome itself he let untouched (probably doesn't have time to do that. - I can understand considering that he's maintaining openbox, lxqt and lxde).
There's an issue with terminus-fonts in rofi there (packagename was changed since the last build of awesome-edition); compton is still used instead of picom. -
Will eventually create another thread about picom, since it doesn't work atm with transparency (had to reinstall awesome since I broke it, and didn't save my config-files. Big mistake! - Got to work everything though in the meantime, except picom as mentioned.)

Nothing special. Under Playback I see a bar for System Sounds and Firefox AudioStream - in the playback. I can get several Firefox AudioStreams (who woulda guessed? :blush:). Moving the bar around here does not change the bars in the panel. To do that I have to look at the Output Devices, where I have just the Line Out connected.

Note on the side:
My volume control in the keyboard (I have a K70 connected) works, but feels pretty sluggish. I had Xfce running in the past and it felt much more responsive there.

Yeah, kinda guessed that. :wink:

No problem! I'm afraid the result is slightly less enlightening, than I had hoped - for me anyways. Or am I missing something (again)?

typ$ amixer -c 0 get Master
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 65 [75%] [-16.50dB] [on]

$ amixer -c 1 get Master
amixer: Unable to find simple control 'Master',0

Normal on that. The amixer commands returned normally, there is a script (/usr/bin/autoalsaconf) and I wanted to check that it only assigned one 'working_card' before filling the volume infos.

I have solved it tho. Did you install the minimal version? If not have you uninstalled or reconfigured any of the pulse components?

I ask because the script that manages the volume icon (/usr/bin/volume_status.sh), checks if you're using pulse or alsa and displays status based on that. When I run the command there to get the volume status from alsa avol level I also get two volumes returned; Left and Right. This is how alsa represents it's levels. The pulse option pulseaudio-ctl -C only returns one stereo status.

Personally I would re-install manjaro-pulse and reboot. This will bring the install in-line with the pkgs and files that should be there. And hopefully solve the issue.

If you'd rather not re-install or you have removed or altered specifically. then editing the alsa script is also a choice. Just add head -1 to the level() function. Below is a copy/paste-able example of the edit. You can just save as /usr/bin/avol (yes to overwriting previously existing version).

#!/bin/dash
#
# Manage ALSA Master channel

test "$1" = "-h" && echo "usage `basename $0` [up|down|mute]" && exit 0

level() {
    amixer get Master | sed -n 's/^.*\[\([0-9]\+%\).*$/\1/p' | uniq | head -1
}

state() {
    amixer get Master | sed -n 's/^.*\[\(o[nf]\+\)]$/\1/p' | uniq
}

test $# -eq 0 && echo "`level` `state`" && exit 0

case $1 in
    up)      amixer set Master ${2:-5}%+ >/dev/null ||autoalsaconfamixer;;
    down)      amixer set Master ${2:-5}%- >/dev/null ||autoalsaconf;;
    mute)      amixer set Master toggle >/dev/null ||autoalsaconf;;
    state|level) $1 ||autoalsaconf;;
    set)    amixer set Master $2% >/dev/null ||autoalsaconf;;
    *)    amixer set Master $1% >/dev/null ||autoalsaconf;;
esac

Hopefully either option fixes the issue! This environment is a little complex and I'm still learning all the moving pieces.

1 Like

Yes! I guess I could add the title back on my profile but it feels silly to me.

As far as the other editions, I would open a support thread in this category with the found issues (would be incredibly helpful if the thread came with suggested fixes too). And just to doublecheck, for sanity, on the picom issue have you changed however it autostarts to call 'picom' instead of 'compton' (or even launching 'picom' from command line)?

1 Like

4 posts were split to a new topic: picom + bspwn issues

I just reinstalled manjaro-pulse. Yup, that did the trick!
Thanks for your help! :smiling_face_with_three_hearts: :+1:

BTW. I still have a strange compositor-issue, that seems to be related to bspwm, because I have never seen that anywhere else. And there is a thing about the startup-sequence. Should I start new threads on those so future users can search for these things better or should I just go on in here?

Best regards,
Cassi

Does it make a difference if picom or compton is used? I was under the impression, that is the same program.

Regards,
Cassi

You afraid of all the fan mail? :rofl:

This thread should be fine, we've covered multiple issues, as titled.

Picom is a fork of compton, yes. However that means the installed binary file is now named 'picom' and not 'comtpon' so all commands need to call 'picom' now. (files will be updated in the bspwm edition v20)

Ha, no, I just feel like an eternal newb and wander into the weeds sometimes overlooking simple things often. So maybe newbies to the forum shouldn't take me as expertly knowledge-able as that title would lead one to think.

Also if you don't mind answering some q's so I can better understand why volume_status.sh chose the alsa option?

  • Did you install the minimal version? (only available in manjaro-architect installs)
  • Have you uninstalled or reconfigured any of the pulse components?
2 Likes

Oh there'll be a new iso?:star_struck:
Will there again be minimal-bspwm, full-bspwm and bspwm-mate?
I might have a look at bspwm-mate. Watched videos, looks promising.
Will need to get used to the tiling-method there though. I'm more into automatic tilers.

Yes! I'm wrapping it up currently.

The minimal and full versions (edit: mate too) are currently and will stay available (edit: I think mate will stay available) with manjaro-architect installation. The iso has both manjaro-architect and Calamares (gui) install options. If you chose to use Calamares then it will default to the full version. I'll check in on the mate variant. I have (in april this year) just inherited maintenance and am still learning the landscape.

3 Likes

From another thread it seems like @produmouse might be setting up bspwm from scratch.

1 Like

So you are human and screw up from time to time? Big deal! That happens to all of us.

Just so you get an idea of my background: As an OS/2 gal I did my first Linux steps with SuSE (there was no open back then) 4.something. I'd have to check in the storage which version it was exactly, but it was the 90s. The distribution came in a box, on 4 CDs and had an actual book. I distinctly remember running the kernel 2.0.36 - and that was by no means the first kernel I had ever installed. Back then I had a Buslogic (Mylex) BT952 SCSI-controller (LVD was a thing back then) and the only way to get that thing to work was to compile a custom kernel - which was quite a pain because the generic kernel wouldn't start up on my machine.

I went into the BSD-world for a long time a while after that. I started out with FreeBSD 3.4 (which also came on CDs) and later took a look at NetBSD 2.0. I remember the fork of FreeBSD 4 that is now Dragonfly - and I remember the reasons. While I did use FreeBSD on the Desktop all that time, I mainly used KDE and Xfce, which I both really liked. I turned my back on KDE as of version 4 and only used Xfce - which I install for people who are computer novices even today. In 2013 I took up a job in a small engineering firm where openSUSE was the only OS used. That made me look at Linux for myself again. I didn't like openSUSE because moving from one release to the next nearly always broke the system and the support cycles were too short for my taste. Ubuntu was not really free and I couldn't arrange myself with Unity either. The other Ubuntus (like Xubuntu) were often quite poorly patched together. Debian was better but the software was partially ancient. In a German computer magazine I read about Antergos. It was fine - if you ever got it to install. Arch was good too, but a pain to install - not hard, but time consuming. And a while back I came to Manjaro and have been pretty happy with it.

The difference between FreeBSD and Manjaro (or Linux in general) isn't all that big in the userland. But the boot sequence is completely different (The BSDs never had SysV and still don't
have anything like Systemd.). The sound system is different and there are a few other things too. I really feel like a newb right now, especially because I have for some dumb reason decided to try out tiling wms, which require a lot of manual leg work. But I am willing to learn.

This gigabyte of text was meant to cheer you up about making mistakes and feeling like a newb from time to time. All is good - and I really appreciate you taking the time to help me with all this stuff! :smiling_face_with_three_hearts:

I don't mind at all! :innocent:

I did use the architect, but I did not install the minimal version. In some cases (like the official Xfce) the minimal install does not only come with less apps installed, but with different apps. In the case of Xfce Midori is installed instead of Firefox. I would have preferred if no browser was installed, so I could just install one, instead of possibly having to remove one and installing another. That is why I usually don't choose the minimal install.

Not knowingly. I have updated the system and I have installed a few applications (like fish, alacritty, mc). But there was no sound relevant stuff in there. I haven't even installed vlc yet. :thinking:

Hope this cheers you up and helps you a bit!

That depends on the definition. :wink:
I have installed Manjaro from scratch on a new SSD, using the architect and the full install of the bspwm desktop. So I have the pre-configured stuff installed as a basis. However I can see no real signs of Mate on my system. This is the output of neofetch:

OS: Manjaro Linux x86_64
Host: X10SAT 0123456789
Kernel: 5.6.11-1-MANJARO
Uptime: 1 hour, 43 mins
Packages: 1008 (pacman)
Shell: fish 3.1.2
Resolution: 2560x1440, 2560x1440
WM: bspwm
Theme: Adapta-Nokto-Eta-Maia [GTK2/3]
Icons: Papirus-Dark-Maia [GTK2/3]
Terminal: alacritty
CPU: Intel Xeon E3-1246 v3 (8) @ 3.900GHz
GPU: NVIDIA GeForce GTX 770
Memory: 4986MiB / 32053MiB

When I tried awesome there was also a line that said

DE: Xfce

Ok, I'll just go on here then... :+1:

When watching youtube, the compositor seems to go AWOL when I switch to full screen. If I have a terminal on the other monitor open (which is frequently the case), the transparency disappears. If I turn off full screen viewing or if a notifications pops up, the transparency is restored. When the notifications goes away again, so does the transparency.

Is this normal?

Forum kindly sponsored by