Issues with Bluetooth Headset Microphone not getting detected and unavailable headset profiles

Hello, everyone. I recently bought myself a pair of Sony hear.on’s (WH-H910N) and a Bluetooth dongle ASUS USB-BT500. The audio works perfectly but my system can’t detect the mic. I tried other solutions I found on this forum or arch forums but nothing helped. I have literally the same error as everybody else
headset_head_unit: Headset Head Unit (HSP) (priority 30, available: no)
but no working solution.

The artificial modem option with ofono was of no use, so I decided to try hsphfpd. In the installation guide they ask to get a PulseAudio patch, since there were no clear instructions I decided to just download a package from AUR, called libpulse-hsphfpd. When I am installing it, there are errors:

FAILED: src/modules/module-echo-cancel.so.p/echo-cancel_adrian-aec.c.o

Fatal error: adrian-aec-orc-gen.h: No such file or directory 30 | #include "adrian-aec-orc-gen.h"

Also, some of the headers are missing, like
Checking for function "paccept" : NO

Info:

name: <bluez_card.14_3F_A6_39_C5_D6>
	driver: <module-bluez5-device.c>
	owner module: 26
	properties:
		device.description = "WH-H910N (h.ear)"
		device.string = "14:3F:A6:39:C5:D6"
		device.api = "bluez"
		device.class = "sound"
		device.bus = "bluetooth"
		device.form_factor = "headset"
		bluez.path = "/org/bluez/hci0/dev_14_3F_A6_39_C5_D6"
		bluez.class = "0x240404"
		bluez.alias = "WH-H910N (h.ear)"
		device.icon_name = "audio-headset-bluetooth"
		device.intended_roles = "phone"
		bluetooth.codec = "sbc"
	profiles:
		headset_head_unit: Headset Head Unit (HSP) (priority 30, available: no)
		a2dp_sink: High Fidelity Playback (A2DP Sink) (priority 40, available: yes)
		handsfree_head_unit: Handsfree Head Unit (HFP) (priority 30, available: unknown)
		off: Off (priority 0, available: yes)
	active profile: <a2dp_sink>
	sinks:
		bluez_sink.14_3F_A6_39_C5_D6.a2dp_sink/#4: WH-H910N (h.ear)
	sources:
		bluez_sink.14_3F_A6_39_C5_D6.a2dp_sink.monitor/#5: Monitor of WH-H910N (h.ear)
	ports:
		headset-output: Headset (priority 0, latency offset 0 usec, available: yes)
			properties:
				
		headset-input: Headset (priority 0, latency offset 0 usec, available: unknown)
			properties:

Does anyone know how to properly install this patch, or is there any other solution for my problem?

Thanks in advance for your help!

Any helpers?