Issues with Bluetooth: hci0: don't support firmware rome

deepin

#1

Hello,

I am using Manjaro Deepin Testing and my Bluetooth is not working as expected. Even though Bluetooth service seems to be working, I could not see the Bluetooth icon in control center.
I have idVendor 0x0cf3 Qualcomm Atheros Communications idProduct 0x3004 AR3012 Bluetooth 4. and it seems to be due to this https://www.spinics.net/lists/linux-bluetooth/msg75196.html. PFB the

 dmesg | grep -i blue 
[   16.185533] Bluetooth: Core ver 2.22
[   16.185572] Bluetooth: HCI device and connection manager initialized
[   16.185579] Bluetooth: HCI socket layer initialized
[   16.185583] Bluetooth: L2CAP socket layer initialized
[   16.185595] Bluetooth: SCO socket layer initialized
[   16.400106] Bluetooth: hci0: don't support firmware rome 0x31010000
[   27.616711] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   27.616715] Bluetooth: BNEP filters: protocol multicast
[   27.616722] Bluetooth: BNEP socket layer initialized

I tried linux 44, 49, 414, and 416
I would really appreciate any help. As you can see the Bluetooth is not showing up in my control center.
image

A similar issue is raised by another member. So I think this could be ignored


[Atheros AR3012] Bluetooth: hci0: don't support firmware rome 0x31010000
[Testing Update] 2018-04-29 - Kernels, Nvidia, MS-Office-Online, Glibc, Firefox, Vertex
#2

See here: https://bugzilla.kernel.org/show_bug.cgi?id=199271


#3

Thanks @philm for reply. So you are saying that it is not fixed in upstream, right? I have given this same issue in the explanation. I didn’t quite understand the solution in bugzilla as in QC says it is not fixed. Am I missing something?


[Testing Update] 2018-04-24 - Linux417, Cinnamon, i3, Python
#4

@philm I could get it working with linux 3.18. I know that I am going backward. But for time being, I think it would be better as I need to use my Bluetooth headset.


#5

The issue is with commit f44cb4b and it was backported to all LTS kernels aswell. The solution is to revert this commit and apply this on top of it.


Manjaro-Realtime-Kernels News
#6

Please try if this fixes the issue for you:

sudo pacman -U https://mirror.netzspielplatz.de/manjaro/packages/pool/overlay/linux416-4.16.6-2-x86_64.pkg.tar.xz


If not online anymore on our servers, please look here.


#7

Thanks @philm. Sorry for the late reply as I was busy with some work yesterday.
I have installed linux416 (currently I have linux416 4.16.6-2) as you suggested and it is working fine. Thanks a lot.

I have checked after recent update on linux49 (linux49 4.9.97-1) and 414 (linux414 4.14.38-1) but they did not work.

Anyway, thanks a lot for the help.


#8

Thx for the feedback. The other kernels will have the fix on Wednesday. See here.


#9

I’d backported the patch to v4.4, v4.9, v4.14, v4.16 and v4.17 by now. You may find those updates today in unstable and soon in other branches too.


#10

It worked for 4.9, 4.14, and 4.16 now. Thank you very much :smiley:


#11

so in order to fix it. i should install regular 4.16 kernel and apply the patch? thanks @walkingzen @philm


#12

PERFECT! just perfect. i can confirm it is fixed now. Just installed the current 4.16.7-1 kernel and it works flawless. THANKS A LOT GUYS @philm @walkingzen