Issues updating to newer kernel

Hello all and thanks in advance, I will do my best to provide everything I can here.

please note that these issues have persisted pretty much since I installed Manjaro at the beginning of 2022 but I have only recently had time to try to troubleshoot.

Hardware: 2022 Razer Blade 17

Display: 4k 144hz (not used, laptop is mostly closed on desk stand)
external display: Asus ROG 2k @144hz
GPU Nvidia 3080 Ti laptop GPU
CPU Alder Lake i9 20 core

My main issues are that some functionality of some features is not working, I suspect due to being on newer hardware with an older kernel.

-wifi not detected (i have been using ethernet at my desk anyway but I would like to use it on wifi when I don’t want to be at my desk)
-onboard microphone(s) not detected
-startup is very fast but shutdown is totally questionable and sometimes hangs indefinitely resulting in a hard power off

There are some other nitpicky things but i’d be happy to just get these issues solved to start.

At one point I had a newer kernel (I believe it was 5.17 or 5.19) and wifi did work but the microphone didn’t. after an update, the previous kernel stopped working and wouldn’t boot so I reverted to 5.15 and tried to unininstall and reinstall the newer one.

Uninstall went fine but both 5.17 and 5.19 are no longer in the kernel list in the settings manager or in the console with

sudo mhwd-kernel -l

I installed 6.0.5 and 6.1.1 thinking the newer versions may offer better support for my hardware but neither of them will boot and no amount of log reading or googling has led me to an answer.

I would not say I’m a complete noob as I have been using linux a while but I have not dug into the customization and tinkering as much as I would like since I have been busy with work. I’m not sure what may be the best place to start, please let me know what information you need and I will do my best. Thanks so much for your help.

Welcome to the forum!

How exactly did you conclude that it wouldn’t boot? We do need specifics.

“It doesn"t boot” is way too vague.

Those kernels are EOL, so we don’t offer them anymore. :man_shrugging:

1 Like

My apologies,

On boot it shows a few errors, one of them “failed to start Load Kernel Modules”

I waited until it confirmed the failed boot, logged into the console and looked at the logs with

journalctl -xb

I saw a few ACPI errors and some that said blacklist, but to be completely honest I’m not well versed enough to know how to decipher boot logs. I don’t know the exact command to get to those same logs from the desktop but I am happy to provide them.


edit: it wasn’t that hard to figure out I have the full log but it’s too big to paste here, what is the recommended method for sharing larger files? google drive?

you have nvidia, so add the ibt parameter and see if it helps:
sudo nano /etc/default/grub
and in this line: GRUB_CMDLINE_LINUX_DEFAULT - inside the quotes add this parameter:
dont remove anything from there, just add it to the existing parameters, save the file with ctrl+x, update grub with:
sudo update-grub
reboot and try the newer kernel 6.1


@brahma ok, thanks I’ve updated the file as directed, I’ll try the reboot now.

@brahma apologies, I forgot to update grub with the second command, I did catch it before I rebooted so I tried running it now and I’m getting

nevermind I checked the file again and had an extra colon on line one, damn you, Vi

/etc/default/grub: line 1: :GRUB_DEFAULT=saved: command not found

unbelievable. I’m on 6.1.1 and it booted without complaining. I wasted HOURS trying to solve this myself to no avail, thank you so much for your help.

if you could please help with one more issue: now that I have accessed the boot menu for grub it will likely appear every time, sometimes I boot into windows to play certain games, but mostly I’m in manjaro 90% of the time and I’d rather it just skip the boot menu unless I tell it somehow that I need to see it by holding shift. can this be automated so that it only shows as needed or is that just the way it is?

I’m sure it seems trivial I just can’t find a clear answer. It boots to the desktop in less than 10 seconds so I’d really like to save the 4 seconds that it sits on that menu if possible

so again edit the grub file and change the following line to look like this:
save grub;
update grub:
sudo update-grub
reboot, and the menu will no longer be shown, and can be accessed by esc or shift

1 Like

Thanks again. Someday I hope to be well-versed enough to pay this forward. All the best.

If you can get to a console, then it has successfully booted, but the errors you were getting are typical if you have an Nvidia graphics adapter and you’re using the proprietary driver. These drivers are kernel-specific and must be updated as well when you switch kernels.

That is understandable. the comment above seems to have resolved it, I don’t think it updated drivers, is that something I should be concerned about? Where can I read more about what ibt is and why it works now that it’s off? I’m thrilled to have solved the issue but I would defiinitely like to understand whats going on here if I can.

nvidia may not boot on Linux 5.18 (or later) on systems with Intel CPUs due to FS#74886/FS#74891. Until this is fixed, a workaround is disabling the Indirect Branch Tracking CPU security feature by setting the ibt=off kernel parameter


Ah ok that does makes sense, I appreciate it! Thanks again!

This will not work. That makes no difference on the boot process and time. However setting a one second timeout will work to shorten the GRUB menu.

As he uses Windows dual boot, it has Windows GRUB menu entry, so GRUB will override some settings, as per this bit in /etc/grub.d/30_os-prober:


adjust_timeout () {
  if [ "$quick_boot" = 1 ] && [ "x${found_other_os}" != "x" ]; then
    cat << EOF
set timeout_style=menu
if [ "\${timeout}" = 0 ]; then
  set timeout=10

Basically GRUB will not hide on a “dual boot situation”, and timeout can not be “0”.

thats interesting, didnt know that you cant hide grub in dual boot with windows…

That’s how OS Prober works apparently…

I appreciate the tip, I will at least change it to 1 second, honestly this may just be the last straw to finally give windows the axe once and for all. I noticed when I went to change it that it was already set to hidden so I just assumed there wasn’t a workaround but this will help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.