Issues installing

Just want to start off saying that this is my first experience with Linux and I am not very savvy with it. That said I’ve been trying to install Manjaro with the Plasma DE for a while now and keep running into the same issues. I’m pretty sure it’s a corrupt image causing the error but I thought I’d post here incase I’m being stupid.

I’ve disabled secure boot and am in UEFI mode in the bios. I’ve booted from the USB, liked the OS and tried the installer which came up with the unpackfs error.
I’ve tried following a tutorial for manual partitioning and that didn’t help. I’ve tried to install a dozen times with the same errors:

Command 'unsquashfs' returned non-zero exit status 1.

File "/usr/lib/calamares/modules/unpackfs/", line 498, in run

File "/usr/lib/calamares/modules/unpackfs/", line 317, in run
entry.do_count() # Fill in the

File "/usr/lib/calamares/modules/unpackfs/", line 89, in do_count
libcalamares.utils.host_env_process_output(["unsquashfs", "-l", self.source], cb_count)

File "<string>", line 3, in <module>

System info:

Motherboard - MSI z97 g45 gaming

CPU - Intel 4790k

GPU GTX 980 Nvidia

check this:
Disable Secure Boot;
Enable AHCI - its under SATA/RAID options;
Disable Optane Memory and Rapid Storage Technology (RST) - you may not have these options;
Disable Fast Boot - you may not have this option;
Disable fast startup from windows;

use ventoy to flash the iso;
redownload the iso again from Manjaro Downloads

provide also system info:
inxi -Faz
use formatting, click this icon in editor: </>

Thanks. The fresh ISO install did it.