Issues after updating xfce4 packages

I’ve updated a few Xfce packages via Pamac > Groups, closed the session and some issues showed up when I came back:

  • My panel is weird now, plugins are not properly shown and there’s something wrong with separator it’s a vertical white bar now
  • Compositor is broken, windows are flashing/flickering as I move the cursor, disabling it solves

Some info:

Kernel: 4.15.0-1-MANJARO x86_64 bits: 64 gcc: 7.2.1
Desktop: Xfce 4.13.1git-UNKNOWN (Gtk 3.22.26)
WM: Xfwm4
WM Theme: Stoneage
Theme: Vertex-Maia-Light [GTK2]
Icons: Vibrancy-Full-Dark-Teal [GTK2]

pacman -Q | grep '\-gtk3'
exo-gtk3 0.11.4-2
garcon-gtk3 0.6.1-3
libfm-gtk3 1.2.5-1
libxfce4ui-gtk3 4.13.4-1
libxfce4util-gtk3 4.13.1-2
spice-gtk3 0.34-2
thunar-gtk3 1.7.0-2
thunar-volman-gtk3 0.9.0-1
xfce4-appfinder-gtk3 4.13.0-2
xfce4-notifyd-gtk3 0.4.1-1
xfce4-panel-gtk3 4.13.2-1
xfce4-power-manager-gtk3 1.6.0.79.g23fc649-2
xfce4-session-gtk3 4.13.0-5
xfce4-settings-gtk3 4.13.1-5
xfce4-whiskermenu-plugin-gtk3 2.1.3-1
xfconf-gtk3 4.13.4-3
xfdesktop-gtk3 4.13.1-8
xfwm4-gtk3 4.13.0-6

My old panel xfce-panel 4.12.2-1:

My new panel xfce-panel-gtk3 4.13.2-1:


(the litle black vertical borders at left and right extremes are not part of the panel, they are just part of a crop of an img)

What branch are you running? I am assuming it is Testing since you have xfce4-gtk3 packages installed. Check and see if you have xf86-video-intel installed. If so try removing it and rebooting. This should take care of the flicker and likely the plugin display issues.

I’ve update Xfce packages manually on Pamac > Groups
Manjaro Linux x86_64 Stable branch

Removing xf86-video-intel? Removing drivers is something that scares me, I’m no expert but I think it can break something.

You will go to modesetting if yiou remove xf86-video-intel. It is not a necessary driver and is the most likely cause of your problem. If you need to you can reinstall from tty. Also check your /etc/pacman-mirrors.conf check the branch. I am very surprised xfce4-gtk3 packages are in stable at all. Did you explicitly install them?

1 Like

Removing xf86-video-intel solved the Compositor issue, thank you. :+1:

The branch:

/etc/pacman-mirrors.conf

Branch Pacman should use (stable, testing, unstable)
Branch = stable

I installed the packages manually with Pamac > Groups > Xfce categories.

I’ve just updated the original post with a screenshot of my old menu for comparison.

To go back to the old panel:
Removed the xfce-panel-gtk3 4.13.2-1
Reinstalled xfce-panel 4.12.2-1

Old panel:

New panel:

I think that xfce-panel-gtk3 4.13.2-1 has some bug, I will stick with the old one for now.

Okay, just remember that those xfce4-gtk3 packages are a development version of Xfce being version 4.13. Also mark the topic solved when you get the chance. Happy it worked out for you.

1 Like

The white bar is because you have a separator and it seems that in gtk 3 it changes it to white, for the white border in the systray, its because you have the show outline(or something, idk i have it in spanish) option marked, the clock problem is because of the vertex maia theme but for the black icon in systray i honestly don’t know, and the flickering happened to me too but i just downgraded xfwm4 to the gtk2 version and it got solved.

1 Like

Thanks, I’m using the new panel now(xfce-panel-gtk3 4.13.2).

I’ve entedered Separator properties and set it to transparent now and well, now it is transparent.

The white border was gone after I disabled Show borders on Notification area settings. It’s a pretty useless feature in my opinion, I’m not sure why anyone would like to see borders there.

The clock still has the wrong color on Vertex-Maia, Vertex-Maia-Light and Vertex-Maia-Square.

That’s how my new bar is looking now with Vertex-Maia-Light:

1 Like

This theme should fix your problem with the clock, i made the fix but it has not been tested as it should, so if you find errors notify me.

I’m using Gnome Shell now, maybe in the future I will give it a try, thanks.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.