Issue with Trackpad Edge Scrolling Recognition

Hi, i’m new to ArchLinux too, but i enjoy it!
Have notices recently when using trackpad on my Lenovo Yoga 910 that it has some big edge scrollbars kind of. They work fine usually, however when i touch it from the edge of the trackpad (left, right and up, as bottom edge doesn’t have anything) it isn’t recognized by the cursor until i touch the trackpad with the second finder and it registers as a scroll then. It’s especially annoying when i try to close the tab with 3 finger tap and it won’t recognize it as i touch the trackpad more on the right side and one of the finger touches that edge. It works flawlessly only when i do right in the center of the trackpad.

Is there an option to disable it or at least to change the size?

P.S. On it’s own the edge scrolling isn’t working, i used this example as it was popular back in the days to have the sides of trackpad reserved for vertical of horizontal scrolling.

Hi @gordanius and welcome to the Manjaro forum

Are you sure you meant ‘ArchLinux’?

Manjaro is based on ArchLinux, however, this is the Manjaro forum. Are you sure you didn’t want the ArchLinux forum?

Might post there too, however i’m also using Manjaro on ArchLinux. Should i do it?

I’m unsure what you mean by that. There is either ArchLinux or there is Manjaro Linux – both are separate distributions.

Could you please post output of:

inxi --admin --verbosity=7 --filter --no-host --width

here’s the output:

System:
  Kernel: 6.5.13-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=3012dcaa-b5fa-4025-91d8-3cc1dade8058 rw quiet splash
    udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 info: latte-dock
    wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro Linux base: Arch Linux
...

I guess you’re right, it’s Manjaro based on Arch Linux. Did i understand it right?

No guesses. It is Manjaro, which is based on ArchLinux.

Now, if you provide the complete output of that command, others should then have better information to enable them to help further. Cheers.

System:
  Kernel: 6.5.13-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=3012dcaa-b5fa-4025-91d8-3cc1dade8058 rw quiet splash
    udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 info: latte-dock
    wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Convertible System: LENOVO product: 80VF v: Lenovo YOGA 910-13IKB
    serial: <superuser required> Chassis: type: 31 v: Lenovo YOGA 910-13IKB
    serial: <superuser required>
  Mobo: LENOVO model: Agera v: SDK0J40709 WIN serial: <superuser required>
    UEFI: LENOVO v: 2JCN39WW date: 05/31/2017
Battery:
  ID-1: BAT1 charge: 50.3 Wh (91.0%) condition: 55.3/78.0 Wh (70.9%)
    power: 11.3 W volts: 8.6 min: 7.7 model: Simplo BASE-BAT type: Li-poly
    serial: <filter> status: charging
Memory:
  System RAM: total: 8 GiB note: est. available: 7.51 GiB
    used: 5.64 GiB (75.2%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: Intel Core i7-7500U bits: 64 type: MT MCP arch: Amber/Kaby Lake
    note: check gen: core 7 level: v3 note: check built: 2017 process: Intel 14nm
    family: 6 model-id: 0x8E (142) stepping: 9 microcode: 0xF4
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 2665 high: 3500 min/max: 400/3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3500 2: 3472 3: 3291
    4: 400 bogomips: 23209
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb erms est f16c flush_l1d fma fpu fsgsbase fxsr ht hwp
    hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep sgx
    smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tsc
    tsc_adjust tsc_deadline_timer vme x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Vulnerabilities:
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel HD Graphics 620 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: DP-1
    off: eDP-1 empty: DP-2 bus-ID: 00:02.0 chip-ID: 8086:5916 class-ID: 0300
  Device-2: Chicony EasyCamera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1:9 chip-ID: 04f2:b5a4
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.9 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.92x11.22")
    s-diag: 581mm (22.86")
  Monitor-1: DP-1 pos: primary model: Dell SE2723DS serial: <filter>
    built: 2023 res: 1920x1080 dpi: 82 gamma: 1.2 size: 598x336mm (23.54x13.23")
    diag: 686mm (27") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 note: disabled model: AU Optronics 0x323d built: 2015
    res: 1920x1080 dpi: 158 gamma: 1.2 size: 309x173mm (12.17x6.81")
    diag: 354mm (13.9") ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 620 (KBL GT2)
    device-ID: 8086:5916 memory: 7.33 GiB unified: yes
  API: Vulkan v: 1.3.269 layers: N/A device: 0 type: integrated-gpu
    name: Intel HD Graphics 620 (KBL GT2) driver: mesa intel v: 23.1.9-manjaro1.1
    device-ID: 8086:5916 surfaces: xcb,xlib
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
    bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
  API: ALSA v: k6.5.13-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: pipewire-media-session status: active 3: pipewire-alsa
    type: plugin tools: pactl,pw-cat,pw-cli
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: Lenovo driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 01:00.0 chip-ID: 168c:003e class-ID: 0280 temp: 44.0 C
  IF: wlp1s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: br-10f877bbf798 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IF-ID-2: br-39a5682ed2f0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IF-ID-3: br-e69d991da1c0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IP v6: <filter> virtual: tentative scope: global
  IP v6: <filter> virtual: tentative scope: link
  IF-ID-4: docker0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
Bluetooth:
  Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 driver: btusb v: 0.8
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-8:5
    chip-ID: 0cf3:e300 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 4 state: up address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 238.47 GiB used: 36.02 GiB (15.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLV256HCHP-000L2
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 5L0QBXV7 temp: 28.9 C
    scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 48.07 GiB size: 47.02 GiB (97.80%) used: 35.99 GiB (76.6%)
    fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5 label: Manjaro
    uuid: 3012dcaa-b5fa-4025-91d8-3cc1dade8058
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 29 MiB (11.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: SYSTEM_DRV uuid: 3C1D-A0CE
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 4 GiB used: 837.1 MiB (20.4%) priority: -2
    file: /swapfile
Unmounted:
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 189.16 GiB fs: ntfs
    label: Windows uuid: B2DC1E49DC1E07ED
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 1000 MiB fs: ntfs
    label: WINRE_DRV uuid: BAE81F00E81EBA99
USB:
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-1:9 info: Chicony EasyCamera type: video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0
    power: 500mA chip-ID: 04f2:b5a4 class-ID: 0e02 serial: <filter>
  Device-2: 1-4:7 info: Integrated Express ITE BillBoard type: HID
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 chip-ID: 048d:5212 class-ID: 0300
  Device-3: 1-5:10 info: Validity Sensors type: <vendor specific> driver: N/A
    interfaces: 1 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1
    power: 100mA chip-ID: 138a:0094 class-ID: ff00 serial: <filter>
  Device-4: 1-8:5 info: Qualcomm Atheros QCA61x4 Bluetooth 4.0
    type: bluetooth driver: btusb interfaces: 2 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 100mA
    chip-ID: 0cf3:e300 class-ID: e001
  Hub-2: 2-0:1 info: super-speed hub ports: 6 rev: 3.0
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 chip-ID: 1d6b:0003
    class-ID: 0900
Sensors:
  System Temperatures: cpu: 61.0 C pch: 40.5 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 263 Uptime: 6h 42m wakeups: 1 Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1332 pm: pacman pkgs: 1321 libs: 357 tools: pamac,yay pm: flatpak
  pkgs: 0 pm: snap pkgs: 11 Shell: Zsh v: 5.9 default: Bash v: 5.2.21
  running-in: konsole inxi: 3.3.31

1 Like

@soundofthunder is this the right output?

Yes, that’s correct.

My intention was to clarify which OS (ArchLinux or Manjaro) you were actually using, and for you provide information that might help others find a solution.

Unfortunately, I have no personal experience with trackpad issues, and am unable to help further.

I’m sure others might, so it’s just a question of patience.

Good luck.

1 Like