Issue with Snap integration in Pamac: "Installing/Downloading" loop and miscellaneous

Hello there.

I would like to know if someone has tested out the Snap integration in Pamac and have an issue similar to mine? See my report below.

According to @guinux, the code that fix the issue should already be in Pamac, but I still have the same issue despite using pamac-gtk 9.0.0rc-4 (and the related Snap plugin package at the same version). Now I wonder if my issue is something specific, under some weird conditions that we have yet to figure out, or if it is a more general issue.

I haven't tested the Snap integration yet on any other machine than my desktop computer. But I would like to know if other people here also face the same issue than me.

Out of curiosity, I just installed the optional package for pamac.
I don't see ANY sign of snap related thing in Pamac.
Are there any installation/configuration/enabling instructions anywhere?


Edit: I edited pamac.conf to enable snaps. No GUI switch before that.
After editing pamac.conf, Snaps appeared, in search and in Settings (new tab).
Any popular snap that I could test installing?

local/pamac-cli 9.0.0rc-4
    A Package Manager based on libalpm with AUR and Appstream support
local/pamac-common 9.0.0rc-4
    A Package Manager based on libalpm with AUR and Appstream support
local/pamac-gtk 9.0.0rc-4
    A Package Manager based on libalpm with AUR and Appstream support
local/pamac-qt 0.3.0-2
    A QT5 frontend for libalpm - early preview version
local/pamac-snap-plugin 9.0.0rc-4
    Snap plugin for Pamac

I tried to install Skype (popular!).

Snap install error:
snap "skype" requires classic confinement

It does not continue, or have any info or Setting to help.


Tried IrfanView (my favorite and heavily/exclusively used image app)
>230MB??? Still downloading...

@Frog

I just tried it with pamac-gtk 9.0.0rc-5 and it installed the Krita snap fine.

@AgentS

It looks like you need to enable classic snap support to install Skype. You can do that with:

sudo ln -s /var/lib/snapd/snap /snap

Maybe this needs to be also integrated to the pamac-snap-plugin , otherwise some snap applications will not work.

1 Like

That's what I meant to say... :wink:
I was just testing pamac. I won't use it. I don't use it. For reasons... :man_shrugging:


BTW IrfanView was installed succesfully. Then I am Greek, major mistake my parents did... :sob:
It works on Wine and needs "something" to be fixed in Wine (fonts, or other).
How?

I have installed IrfanView in the past, on Wine (no snap) and I could start troubleshooting Wine (for all Wine apps). On Wine-snaps, you have to do this on ALL!! :scream:
I hope it's fine with non-Wine apps, but still... it 's Off Topic. :vulcan_salute:

1 Like

I also failed to reproduce the issue with pamac-gtk 9.0.0rc-5, with VLC.

Preparing...
Downloading vlc
Fetch and check assertions for snap "vlc" (1049)
Installing vlc
Mount snap "vlc" (1049)
Setup snap "vlc" (1049) security profiles
Make snap "vlc" (1049) available to the system
Automatically connect eligible plugs and slots of snap "vlc"
Connect vlc:desktop-legacy to snapd:desktop-legacy
Connect vlc:network to snapd:network
Connect vlc:removable-media to snapd:removable-media
Connect vlc:desktop to snapd:desktop
Connect vlc:home to snapd:home
Connect vlc:unity7 to snapd:unity7
Connect vlc:screen-inhibit-control to snapd:screen-inhibit-control
Connect vlc:opengl to snapd:opengl
Connect vlc:x11 to snapd:x11
Connect vlc:optical-drive to snapd:optical-drive
Connect vlc:pulseaudio to snapd:pulseaudio
Connect vlc:network-bind to snapd:network-bind
Set automatic aliases for snap "vlc"
Run install hook of "vlc" snap if present
Run configure hook of "vlc" snap if present

Well, that folder is normally part of our snap package. Will check the Skype snap later ...

$ pacman -Qo /snap
/snap is owned by snapd 2.41-1

The problem seems to be that skype requires the --classic parameter to successfully install with snap.
Gnome Software is able to install Skype.

sudo snap install skype                                                  
[sudo] Passwort für geggo: 
error: This revision of snap "skype" was published using classic confinement
       and thus may perform arbitrary system changes outside of the security
       sandbox that snaps are usually confined to, which may put your system at
       risk.

       If you understand and want to proceed repeat the command including
       --classic.
sudo snap install --classic skype                                     [1]
Download snap "skype" (92) from channel "stable"

Renamed the topic so it can include any kind of issue encountered, including the one with Skype.

Just a little "up" because the problem is still present.

1 Like

Forum kindly sponsored by