Issue With Permissions


#1

Just built a new system. Dual boot with win10. Everything is fine except some permissions.

I have the storage discs from the old build, ntfs format.

Problem is that these ntfs discs will not let me transfer files onto them or off. ( In win10 it’s OK)

I can transfer from ntfs to ext4.

I cannot transfer from ext4 to ntfs nor from ntfs to ntfs. Not even in root. It’s got me. :hot_face:

UEFI & fast boot disables.


#2

How are you mounting the ntfs partitions? Do you have ntfs-3g installed?


#3

ntfs-3g is up to date. The drive are mounted in fstab.

Example:
UUID=1810F52415691AFD /run/media/hipster/Extra/ ntfs defaults 00
UUID=0E3318DA1445326D /run/media/hipster/StalkerMods/ ntfs defaults 00
UUID=4571503442E56292 /run/media/hipster/Windows/ ntfs defaults 00


#4

You need to use ntfs-3g in fstab instead ntfs. You probably also need to set permissions. Let me see if I have an example around still.

EDIT: Like this:

UUID=1810F52415691AFD /run/media/hipster/Extra  ntfs-3g uid=1000,gid=1000,dmask=022,fmask=133,nofail 0 0

#5

Got a step closer. When I look at the permissions now 2 are auto login, the other is hipster.

The auto logins work but hipster does not.

(gotta go for a while. my turn to cook)


#6

If you are having problems reading/writing your NTFS drives then Windows may be causing this.

In Windows:

Disable hybrid sleep
Disable fast startup
Disable hibernation completely: in an elevated command prompt, run “powercfg /h off”

Even if you have disabled these features in Windows in the past you should recheck their status.

Windows update may have re-enabled these without your knowledge.

You may need to mount your NTFS drives via fstab using the correct NTFS permissions options.

Make a back-up of your fstab file before you make any modifications to it:

sudo cp /etc/fstab /etc/fstab.bak

Below is an example of how you would want to mount your NTFS drive via fstab:

UUID=YOUR_UUID /media/data ntfs-3g nofail,noatime,rw,user,uid=1000,gid=1000,dmask=022,fmask=133,windows_names,auto 0 0

You must substitute your partitions actual UUID for “YOUR_UUID” in the above fstab load line.

You can find your drives UUID from the output of "sudo blkid -o list", (or from within your graphical partition manager utility).

You must also substitute your actual drive name and path for “/media/data” in the above fstab load line.

To set the ownership permissions, use the “uid” and “gid” options as in the above fstab load line.

You can find your UID with the command "id -u". To find your GID, use "id -g". These values are both normally 1000.


#7

Big thanks @dalto & @tbg. All fixed.

Using tbg’s fix got it going. Only difference in there was the GID. Mine was 1001.

Bloody windows! :sob:

Thanks again.