Issue with pamac installing or updating

I have only had Manjaro installed for 2 days and I think I have broken it somehow. When I try to do an update or install new software in pamac I get the error “target not found: launcher-ot-minecraft”. This is an application that I installed for my son via a snap but I have tried to remove it as well and I get the same error when the application is no longer installed. I have read a few posts that recommended a “sudo pacman -Syu” and a “sudo pacman -Syy” which both did not fix the issue. It has also asked me to look at the /etc/pacman.conf but I do not see anything out of the ordinary. Please help me fix this issue as I have no idea what I did wrong here. Also possibility on what I might have done wrong would be helpful as well.

I have done some testing and I am still able to install software via sudo pacman -S no issues but just not via pamac. Hopefully this helps

pacman does not handle Snaps, FlatPaks, or the AUR. You can use pamac ─ which is a different tool ─ to manage those, although Snap packages are sometimes also managed via the snap command.

I’m guessing that whatever you did to uninstall that particular package did not properly work, but we have no idea what you did unless you tell us. :man_shrugging:

Please look closely at my post. I am using pamac the gui tool not pacman. I only brought up pacman to say that it does not also seem to be broken. Also to remove the package I used sudo snap remove launcher-ot-minecraft but the issue happens with the package installed and removed.

I did see that, just as I also did see this:arrow_down:

snap must be used without sudo.

Have you tried… :arrow_down:

pamac remove launcher-ot-minecraft


Just curious, you said “snap must be used without sudo” but every time I try just snap remove packagename it just prompts for a password and sudo prevents that from coming up. If this is the case and it requires admin why would I not use sudo?

That’s a good question. It will indeed prompt you for a password when needed, but it does all operations for which superuser access would be dangerous and unnecessary as your regular user account. This also has some consequences with regard to its database of installed packages ─ possibly with regard to the permissions on said database.

Unfortunately, I don’t use Snaps or FlatPaks, so I don’t have that installed, and I cannot really give you any information on where it stores that database ─ other forum members might, though.

Nevertheless, if you use pamac, then you should normally also be able to install and remove Snaps, as long as you have the Snap system installed.

I tried to run “pamac remove launcher-ot-minecraft” I get “Error: target not found: launcher-ot-minecraft”

Also I have to say that I am not trying to install launcher-ot-minecraft. That is just the error that it throws. I can be trying to install any software from pamac and it will tell me that same error.

Okay, then let’s try it the other way around. Try installing it first… :arrow_down:

pamac install launcher-ot-minecraft

If there’s any leftover crud from its previous installation, then this should set the record straight in the package database, and then you may be able to uninstall it later.


Hmm, just discovered something. There are Minecraft packages in the AUR, but their name differs from what you say you installed. So perhaps the name of the package was changed in the meantime, causing snap to get confused about the package existing and not existing on your system. :thinking:

The AUR versions of the package are called minecraft-launcher and minecraft-launcher-cmd. (According to the AUR, those would be the official packages from upstream.)

No idea what happened but when I ran “pamac install launcher-ot-minecraft” I get “Error: target not found: launcher-ot-minecraft” but the issue has gone away. I tried to update an application and it was able to complete.

Best is to not update a single application, because this will eventually lead to a partial upgrade scenario, and thus a broken system.

Update the whole system, like so… :arrow_down:

pamac update --aur --devel

The only way I have installed applications is in the gui so far until I got the error the first time. That is when I started trying to do the terminal commands to see if they helped. Is this something I would need to run even if that was the case?

Personally, I always advise using the command line, because it is much more verbose and much more flexible. But do make sure the pamac GUI is closed before using it from the command line, or else you’ll be getting errors about a locked database.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.