Issue with installing XP Pen

Hi, I’m having an issue with trying to set up XP Pen. I got all the files in the correct directory but apparently when I try running the install shell file using ./, it gives me a prompt saying “cannot find driver’s rules in package”. Even though I placed the .rules in the correct directory. I have an XP Pen 12, and I used this link.

And when I inspected the via root, it’s also giving me “Cannot find driver’s rules in package” when I try to run the XP Pen Drivers program I see in my search.

System info via Neofetch:

OS: Manjaro Linux x86_64 
Host: Inspiron 15-3567 
Kernel: 6.0.6-1-MANJARO 
Uptime: 5 hours, 55 mins 
Packages: 1148 (pacman), 39 (flatpak), 16 (snap) 
Shell: bash 5.1.16 
Resolution: 1366x768, 1920x1080 
DE: Xfce 4.16 
WM: Xfwm4 
WM Theme: Matcha-sea 
Theme: Matcha-dark-sea [GTK2/3] 
Icons: Papirus-Maia [GTK2], Adwaita [GTK3] 
Terminal: xfce4-terminal 
Terminal Font: Monospace 12 
CPU: Intel i5-7200U (4) @ 3.100GHz 
GPU: Intel HD Graphics 620 
Memory: 5215MiB / 7814MiB

there is this package in the AUR

AUR (en) - xp-pen-tablet

probably better to use that

Wait, what do I do with this? :sweat_smile:

It’s an information for you.

You look up how to operate your package manager
how software is installed when you use a Manjaro/Arch system
and once you know
you use it to install that package.

I still don’t understand what this means. I know how to kinda operate my package manager, but I don’t know what I’m supposed to do with what you sent. I’m not exactly bright when it comes to being left in the dark when given vague info.

Have you tried to type the name of that software into it, to look for it?

Have you tried to learn what the AUR is and how you can use it?

I’m giving “vague” info because I’m reluctant to tell you here by writing it all down yet again
when all that information can be easily found when you look for it yourself.

I’m out - good luck!


This was covered on the forum before. Please follow this

1 Like