Issue with external HDD

I have a curious issue ( for me) with an external hdd, first I had lost the partitions (dont know why), I ran the testdisk on Manjaro and it recovered my partitions with the information, then I needed to copy some info from the hdd to a different machine running MX Linux but when I connected the disk its not recognized, I tried with a third machine running Kali Linux but nothing the same problem, I ran the partition program on MX but it says the disk has no partition but when connected back to the laptop running Manjaro it is recognized and its working fine. Im sharing an image where you can see a lock symbol on one of the partitions, thank you.

You can also see that it is mounted to /run/media/wherever

Perhaps you don’t have the NTFS driver installed on those other distros.

got you, thank you…mmm does the partition tool on MX need the drivers in order to recognize there is a NTFS part present?

Don’t know anything about MX; but look:

pacman -Si gparted
Repository      : extra
Name            : gparted
Version         : 1.1.0-1
Description     : A Partition Magic clone, frontend to GNU Parted
Architecture    : x86_64
URL             :
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : parted  gtkmm3
Optional Deps   : dosfstools: for FAT16 and FAT32 partitions
                  jfsutils: for jfs partitions
                  f2fs-tools: for Flash-Friendly File System
                  btrfs-progs: for btrfs partitions
                  exfat-utils: for exFAT partitions
                  ntfs-3g: for ntfs partitions
                  reiserfsprogs: for reiser partitions
                  udftools: for UDF file system support
                  xfsprogs: for xfs partitions
                  nilfs-utils: for nilfs2 support
                  polkit: to run gparted from application menu
                  gpart: for recovering corrupt partition tables
                  mtools: utilities to access MS-DOS disks
Conflicts With  : None
Replaces        : None
Download Size   : 1734.46 KiB
Installed Size  : 7213.05 KiB
Packager        : Christian Hesse <>
Build Date      : Mon 20 Jan 2020 02:17:02 PM EST
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Optional deps need to be installed; under Arch, they are not automagically installed for you.

Ok, Understood, I’ll apply all the necessary updates, thank you.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.