Issue with Catfish

Hey guys. When I open catfish, I need to delete the pre-written “file search” in the search bar to enter my own query, and that’s getting really frustrating. Does any body have an idea how to resolve it?

Many thanks

That’s not the case on my xfce.

Starting ‘Catfish File Search’ from the main menu the window opens with the search bar empty, only after clicking on the 3 dots at the top right the menu opens and ‘Search for Files’ appears in the search bar. A click in the search bar then clears the text again, as it should.

All updates done? Reinstall catfish? Maybe a theming issue?

I can’t reproduce this either.

Catfish immediately starts with a cursor in a blank text field. (Doesn’t matter if I start Catfish from the menu, terminal, or from within Thunar).

Even if I search for a term, the next time I launch Catfish, it starts all over with a cursor inside the blank search field.

Nailed it!

that’s right. the search bar pops up empty when the application is launched from the whisker menu, but the text appears when I use shortcut for opening catfish. Could you find a way to tackle this please?

I can’t reproduce it either. Which shortcut do you use?

…this is not clear… you “right-click” inside the thunar filemanager ?
If so, then it is a thunar-custom-action .

  • Open thunar - in the menu-bar click edit - open custom-actions
    …and show the content.

man catfish shows command to launch catfish search can include search path or text query

    catfish [options] path query

Behaviour described in OP can be replicated with:

catfish file search