Issue creating bootable USB KDE

For the past few days, I've been trying to install Manjaro KDE onto a bootable USB. This has, however, not worked yet. I downloaded the ISO file from https://manjaro.org/download/official/kde/, checked the checksum (before and after the failed installation attempts), but it still didn't work. What I have tried and what errors came up:

Installing with Rufus: When installing with Rufus, and trying to boot from the USB, I get the 'invalid signature' message. From what I've read, this means I should use DD mode in Rufus, however, I don't get any popup nor do I see any option to select DD mode. I've tried this on multiple versions of Rufus, but no version managed to succesfully create a bootable USB.
Installing with Etcher: Same problem as with Rufus: Invalid signature, no option for DD.
Installing using "sudo dd ..." as explained on the wiki page https://wiki.manjaro.org/index.php/Burn_an_ISO_File. This method also led to an "invalid signature detected" error when booting.
Turning the ISO into an isohybrid using the isohybrid command (run from a kubuntu drive): This gives me an error that the iso only contains an isolinux-debug.bin file, but not an isolinux.bin file, which makes it so the iso can't be turned into an isohybrid.

The USB should not cause any problems. I have succesfully installed Kubuntu on that exact stick in the past. It is an 8GB stick so it should also be big enough.
The ISO file should be correct. I have redownloaded it multiple times, checked the checksum each time before and after the (failed) installation attempts, and each time it matched up with the checksum displayed on the download site.

Am I missing something? What can I do to fix the issue's I keep having?

Did you disable Secure Boot in the firmware/ Bios settings?

1 Like

Disabling Secure Boot indeed appears to have fixed the issue. Thank you for your reaction.

You're welcome!
And Welcome to Manjaro community!

1 Like

Forum kindly sponsored by