ISO build fails due to a bad mirror (GitHub Actions)

I managed to set up a GitHub action to build an ISO and everything went well for the first build.

However the second and 4 other tries failed because the process is trying download packages from which doesn’t seem to serve any manjaro packages right now. Odd it keeps reaching out to the same mirror? Is it hard-coded somewhere?

You can see the workflow history here

:: Synchronizing package databases...
error: failed retrieving file 'core.db' from : The requested URL returned error: 404
error: failed to synchronize all databases (failed to retrieve some files)

I tried using custom-repo field of the action but it fails as well. Is there any other way we can supply a custom mirror?

You should update your manjaro-tools.config.

The moson mirror was decomissioned long time ago.

I read some posts already about it but that’s not the case for me. ISO is being built on the runner used by the GitHub action which I have no control of.

This is the action:

That GitHub action does not mention/contain the mirror you have problems with.

Instead of manjaro/manjaro-iso-action@main, please refer to the most current release (e.g. manjaro/manjaro-iso-action@v1).

1 Like

Got the versioning right but whoops I missed that field among the plethora of fields :sweat_smile:
That solved it (building right now), thanks for pointing it out @linux-aarhus :+1: although its odd to have the value changed from the existing default.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.