Is Thunar (XFCE) right click - create new document menu gone?


#21

No sadly it didn’t help.


#22

touch ~/Templates/Empty\ Document


#23

There is something strange going on with the languages. As you can see i switched all to French and the Trash is displayed in Romanian, and the folders in my home are in English. This is a VBox install i didn’t tempered with …

Still, i can create new documents from Thunar.


#24

I must say again, it work fine on my AMD video card equipped machine (opensource driver). Strange.
Let me try to return to the opensource driver on the Nvidia machine.


#25

The driver for GPU would not affect the way that menu works …
Please provide the output for:
cat ~/.config/user-dirs.dirs
and
cat ~/.config/user-dirs.locale


#26

Btw it is the same issue in VirtualBox so it may not be Nvidia related. Still Thunar is very slow to close too.


#27

$ cat ~/.config/user-dirs.dirs

XDG_DESKTOP_DIR="$HOME/Bureau"
XDG_DOWNLOAD_DIR="$HOME/Téléchargements"
XDG_TEMPLATES_DIR="$HOME/Modèles"
XDG_PUBLICSHARE_DIR="$HOME/Public"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Musique"
XDG_PICTURES_DIR="$HOME/Images"
XDG_VIDEOS_DIR="$HOME/Vidéos"

$ cat ~/.config/user-dirs.locale
fr_CA

(gee hash character doesn’t work here )


#28

Hum more testing. I had a month old XFCE virtual machine and the problem is not there (virtualbox). So it seems something coming in from recent updates.


#29

Nothing i tried to reproduce the issue worked, and trust me i know how to break things :slight_smile:
Do you have something inside the folder?
ls ~/Modèles
What i noticed, that adding a big number of template file formats there it made Thunar to respond slower, but was still able to display all the list and create them without crash.

Not sure is from an update in this case, as i have all 3 branches and none fails.


#30

I am trying to install nemo, if that’s the same issue as I have with it, in that working VM machine without upgrading everything. I use ;
“pamac install nemo” but it want to update everything. Is there a command to install only that ?


#31
sudo pacman -S nemo

#32

Thanks but it want nemo 3.8 which is not there anymore. How do I tell the system that I need only the new pamac without having to deselect 286 upgrades ?


#33
sudo pacman -S pamac

If nemo 3.8 is not in the repo anymore then the only chance is the Arch archive

https://archive.archlinux.org/packages/n/nemo/

But if you have 286 upgraded packages waiting - I strongly recommend doing that upgrade. After all this is a rolling release and maybe your issue resolves after the update.


#34

Before you install Nemo … can you check if what happens in Thunar in your user, happens in a new TEST user too ?
Partial updates are not working in a rolling release :slight_smile:


#35

“There is something going on with files management after recent updates.”


#36

Ok I did the deselect manually and only install the new pamac. Now I got Nemo 4 which works like a charm, very fast. I will try to install the updates by item to zero in the problem.

@fhdk if you follow the thread that’s the full update which brought me the problem. Only that old vm works.


#37

Here are the 284 updates requires. I know it is a pain in the $ and may not work but If someone can suggest which packages chunk should I install first, that’ll save me some time. Those packages which may be related to this issue first. Of course some others would be pull it I guess.

It is only a VM which I have snapshot so it doesn’t matter if I toast it.

284 mises à jour disponibles:
a52dec 0.7.4-10 extra


#38

VM = virtual machine?

  1. backup
  2. update
    if fail
  3. restore

#39

Yes I will proceed methodically. Remove the unrelated first to reduce the numbers. So far it is not XFCE4*, nor systemd.


#40

Na damn it. I did a full upgrade on that old VM first and the problem did not appear. The other new VM has it.
So no idea for now.