Is there a reliable way to connect via remote desktop to manjaro-plasma (arm)

After a lot of fiddling I got tigervnc working but I get constant popups of the same error no matter if I type in the password or not: " System policy prevents Wi-Fi scans". The error has a title: "Authentication required - PolicyKit1 KDE Agent.

Not only is this extremely annoying, the error popups every 30-60 seconds or immediately if you touch the network settings, this also prevents any changes to the network settings which is the thing I really need.

A lot of googling has led me to believe this might have something todo with that I am connecting remotely but I am not sure.

Basically all i want is to have one ongoing session that I can connect to via remote desktop and that doesn’t close any running programs if I exit the remote session, it should all be running in the background and also be there when I log in again. (I don’t want the remote connection to spin up a new login and logout when I disconnect)

Is there any guide to achieve this? Ideally without commercial proprietary solutions like teamviewer.
This basically works without any effort on Raspbian, but its repositories are so old its useless as an OS.

Modern remote desktop viewer app for Linux (Manjaro) that is secure and updated and open source (FOSS)?

I have 2 computers in LAN, both Linux Manjaro XFCE desktop.
And i want to work remotely (on desktop, move mouse etc.) on computer B while siting in-front of computer A. RDP app should be available automatically after boot, no need to start it manually.

What is the modern and secure and simple way to setup this?

My findings so far:

1 - maybe INSECURE, see:
TigerVNC is extremely insecure and should not be used. · Issue #601 · TigerVNC/tigervnc · GitHub
secure connection how ? · Issue #555 · TigerVNC/tigervnc · GitHub
TigerVNC - ArchWiki (see warnings)
SecurityTypes config option possibly should list (at a time of writing) only: “X509Vnc that combines standard VNC authentication with GNUTLS encryption and server identification”
@Fabby mentioned how to setup the things, yet his tutorial is i believe insecure, someone should ask him to update it (he ignore me possibly).

X2go doc:newtox2go [X2Go - everywhere@home]

Packages are in official repos:
pamac install x2goclient


pamac install x2goserver
sudo systemctl start x2goserver.service;sudo systemctl enable x2goserver.service;
sudo sed -i “s|#X11Forwarding no|X11Forwarding yes|g” /etc/ssh/sshd_config;
sudo systemctl reload sshd
sudo x2godbadmin --createdb

open client x2go gui and in new session use Session type X2Go/X11 Desktop sharing. To exit session, remember well the keyboard shortcut Ctrl+Alt+T and +F and +M. (else you may be locked in full screen session)
PROBLEM1 is that i can not make it play in high FPS, it is like 3 fps instead of like 25 or 30.
PROBLEM2 is that clipboard sharing does not work, despite enabled

3 package remmina is available in official repo. I have not tried it.
pamac install remmina

Vinagre seems to be only viewer: Apps/Vinagre - GNOME Wiki!

others List of applications - ArchWiki

but the mentioned question remains

Unless you don’t have any personal issues using google software on your computer, google remote desktop works very well.

Realvnc is the only one I’ve gotten to work reliably. All computers on my home network are connected through Realvnc, two Manjaro KDE laptops, one Raspberry Pi and one Windows 10 desktop.