Is mousepad confused by a folder link?

For convenienmce I created a link on my desktop to /srv/http (the apache server root).
I use mousepad to edit a script in there, but it looks like when I save the file it is creating a new “shadow” copy … somewhere in my desktop folder (that’s mounted on a different drive), rather than modifying the original.
It’s definitely NOT what I want, but how do I avoid doing that?

1 Like

By default those folders require admin privileges to be able to write files. Did you changed permissions (i hope not) or have you tried to make use either of Thunar Root or open that folder by this command:
You can Create Launcher for that, by right click on desktop and use for command field:
thunar admin:////srv/http/
and for working directory

Call it as you want. It will always ask for your password first time, trough polkit.

I created a group called “network” and gave that group read/write/execute permissions… then assigned myself to that group. Is that not the right way to do it? (Note: I’ve only recently moved from Windows and tend to think of my computer as a personal computer… in a secure environment… not used to this multi-user paradigm).

You need to start from scratch and leave Windows concepts behind. :slight_smile: This is my recommendation for you to read about groups:
From that:

So, what you did you should undo. And try my proposal.

1 Like

I see it’s a lot more complicated and I need to digest this multi-user malarkey!. The localhost on my own machine is very much intended for experimental and interactive development and not for anyone else.

At the moment I think conceptually I want it hosted somewhere in my home folder where I can edit it easily without special permissions. Note: /home I have mounted on a separate drive and it gets backed up along with any other work I do and it was indeed a big mistake to start editing the files /srv with modified or elevated privileges.

Instead I now think I will implement it as a virtual host in Apache and leave system folders totally intact (other than the necessary entries in /etc/httpd/conf/ of course).

I spent many hours trying to make that work but eventually I gave up. Feeling very irate and frustrated I shall for now stick with what works and I can’t help but feel the whole mainframe multi user concept was a dead end in evolutionary terms as our average personal cell phone would blow the doors off those time sharing mainframes that Unix was developed for… I really wonder how much bloatware could be economised with a dedicated single user Linux implementation… sorry for the rant… a bit unhappy at the moment ;o)

Another thing to read: Linux File System Hierarchy.

And look at it this way: *nix was built from the ground up with multi-user, networking in mind, so if it works flawlessly on your machine, pushing it to a server outside of your environment will be easy.

Linux is very different under the hood from Windows, though both have:

  • a monolithic kernel
  • their own preferred file system
  • a GUI (or multiple GUIs under Linux)

They’re subtly different and once you treat it as its own thing different from Windows (which has its origins in MS-DOS: a single-user, single-tasking OS), you’ll start becoming like us and become irate and frustrated with Windows as you can’t make that one jump through hoops like you can with Linux…

:wink: :grin:

1 Like

Yes… it’s very logical and it helps to understand the structure so I know where to find things. My approach has in the past always been to make everything into stand alone self contained entities that can be zipped up and unzipped again somwehere else with no loose ends, but Microsoft messed that one up real good with their “registry”. I definitely prefer the Linux way to that MS registry abomination! :smiley:

1 Like

Note: this was result from coversation and my first attempt to post it here messed up as I forgot to replace Update: I finally fixed my problem: what I needed is entries in /etc/hosts localhost quiet-PC

that’s in addition to the virtual host conf file of course

<Directory “/home/angelica/http/”>
   Options +Indexes +FollowSymLinks
   AllowOverride All
   Require local

   DocumentRoot “/home/angelica/http”
   # needs entry quiet-PC in /etc/hosts
   ServerName quiet-PC

This having relevant stuff distributed over different files and folders is going to take some getting used to for an “old fart” like me :crazy_face:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.