Is Manjaro-ARM 64 bit?


#1

After reading about all the compatibility issues using a 64 bit kernel, I settled with using a 32 bit distro on my RPi3. Has this changed in the recent year?

Does X and 3D acceleration + all other stuff that wouldn’t work before, work now in 64 bit mode?


#2

For Raspberry Pi devices, no, it uses 32 bit kernel. Although it would be fun to play with 64bit OS on RPi, it doesn’t have any real advantage from 32bit.
Actually it does have disadvantages, like it would use more RAM running a 64bit OS in it, something that RPi lacks quite easily depending on what you do with it.

There are some distros that supports a 64bit OS for RPI3, but all have a problem related to hardware support.


#3

Thanks, I didn’t realize there were different kernels for different devices. Forgot that ARM does not equal x86/x64. :slight_smile:


#4

There are several AArch64 architecture implementations for RPi3, I tried several of them, they are all pretty bad.

I tried Arch, I couldn’t install several packages.
On Suse I got various segmentation faults, didn’t have time to explore.

Anyways, it seems like the community is not ready yet for full AArch64 support, I’ve seen Nvidia Jetson TX2 with AArch64 Ubuntu and it worked flawless but on RPi there’s still some way to go.


#5

Manjaro-ARM uses armv7h for the Raspberry Pi images, because the aarch64 packages/kernels for the Raspberry Pi have way to many issues.

So far we only have 1 device supported that use aarch64 (64-bit) and that’s the Odroid-C2.

I agree, it would be awesome to get aarch64 to work on the Raspberry Pi 3, but until they get more RAM, it really is only a downside.


#6

Until they come default with 4GB, which is what is currently “rumored” .

https://www.techworld.com/developers/raspberry-pi-4-release-date-new-features-3673222/


#7

According to the article they speculate the RPI4 to having 2-4 GB RAM, so it will probably be 2 GB on that price point. They also speculate on it having USB-C, but again, I doubt that with the price point.