Is it possible to retrieve data or reboot is the only option?

Hello everyone!! I recently started using manjaro( first time user). There was an update a week ago around 5 to 6gb so i left my laptop open and came after an hour, my laptop was shut down. When i open it say Error: file ‘/boot/vmlinuz-5.15-X86-64’ not found you need to load the kernel first press any key to continue

I use dual system along with windows 10
when i click on advanced manjaro option it has two option 1.manjaro something 64bit 2. manjaro something 64bit initramfs along with E= edit C= grub command.

There is same question with solution to it but somehow i am not able to understand it and where and how to insert the commands.

If possible i want to retrieve my data
Thank you in advance.

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

You can also use Maxi

to collect information about the boot process. This works,

  • when you are in your running system (with CTRL+ALT+F2).
  • And also in a live environment

:point_right: It seems your kernel is missing after a partial update

  • You have to reinstall your kernel using a live manjaro
  • Use chroot to get into the system
  • Then re-run the update

To give more specific instructions, it is necessary to provide inxi output

1 Like

i made it easier for you:

  1. boot into a manjaro usb - download manjaro iso, flash it onto usb and boot it
  2. open terminal and run this command:
    sudo manjaro-chroot -a
  3. run update again:
    pacman-mirrors -f 5 && pacman -Syyu
  4. if there were some update issue, post the errors here, together with the formated output from these commands:
    inxi -Fazy
    mhwd-kernel -li
    mhwd -l
    mhwd -li

thank you for replying
so this means i need to reinstall right?

no you dont need to reinstall, only the kernel, and the graphics drivers… follow the steps in the post above, then report back …


Thank you for replying. I am sorry i don’t really understand what you trying to say. If i understood some of the things correctly you want to reboot?

Thank you will be doing now

My data will be erased right?

no your data will not be erased! dont worry

1 Like

Thank you i am ready to run now
Btw i ran the command you told to

  12Kernel 5.15.25-1-MANJARO 12arch x86_64 12bits 64 12compiler gcc 12v 11.2.0
    12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=manjaro misolabel=MANJARO_KDE_2124 quiet systemd.show_status=1
    apparmor=1 security=apparmor driver=nonfree nouveau.modeset=0
    i915.modeset=1 radeon.modeset=1
  12Console N/A 12wm kwin_x11 12Distro Manjaro Linux 12base Arch Linux
  12Type Laptop 12System Acer 12product E5575G 12v V1.32 12serial <filter>
  12Mobo Acer 12model Ironman_SK 12v V1.32 12serial N/A 12UEFI Insyde 12v 1.32
    12date 10/24/2017
  12ID-1 BAT1 12charge 25.8 Wh (100.0%) 12condition 25.8/41.4 Wh (62.3%) 12volts 16.8
    12min 14.8 12model PANASONIC AS16A5K 12type Li-ion 12serial <filter> 12status full
  12Info 12model Intel Core i5-7200U 12socket U3E1 12bits 64 12type MT MCP
    12arch Amber/Kaby Lake 12note check 12family 6 12model-id 0x8E (142) 12stepping 9
    12microcode 0xEC
  12Topology 12cpus 1x 12cores 2 12tpc 2 12threads 4 12smt enabled 12cache 12L1 128 KiB
    12desc d-2x32 KiB; i-2x32 KiB 12L2 512 KiB 12desc 2x256 KiB 12L3 3 MiB 12desc 1x3 MiB
  12Speed (MHz) 12avg 700 12min/max 400/3100 12base/boost 3000/8300 12scaling
    12driver intel_pstate 12governor powersave 12volts 1.0 V 12ext-clock 100 MHz 12cores
    121 700 122 700 123 700 124 700 12bogomips 21607
  12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  12Type itlb_multihit 12status KVM: VMX disabled
  12Type l1tf
    12mitigation PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  12Type mds 12mitigation Clear CPU buffers; SMT vulnerable
  12Type meltdown 12mitigation PTI
  12Type spec_store_bypass
    12mitigation Speculative Store Bypass disabled via prctl and seccomp
  12Type spectre_v1
    12mitigation usercopy/swapgs barriers and __user pointer sanitization
  12Type spectre_v2 12mitigation Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  12Type srbds 12mitigation Microcode
  12Type tsx_async_abort 12status Not affected
  12Device-1 Intel HD Graphics 620 12vendor Acer Incorporated ALI Aspire E5-575G
    12driver i915 12v kernel 12ports 12active eDP-1 12empty DP-1,HDMI-A-1 12bus-ID 00:02.0
    12chip-ID 8086:5916 12class-ID 0300
  12Device-2 NVIDIA GM108M [GeForce 940MX] 12vendor Acer Incorporated ALI
    12driver nvidia 12v 510.54 12pcie 12gen 1 12speed 2.5 GT/s 12lanes 4 12link-max 12gen 3
    12speed 8 GT/s 12bus-ID 01:00.0 12chip-ID 10de:134d 12class-ID 0302
  12Device-3 Realtek HD WebCam 12type USB 12driver uvcvideo 12bus-ID 1-7:4
    12chip-ID 0bda:57f2 12class-ID 0e02 12serial <filter>
  12Display 12server 12v 12compositor kwin_x11 12driver 12X
    12loaded modesetting 12alternate fbdev,vesa 12gpu i915 12display-ID :0
  12Monitor-1 eDP-1 12model AU Optronics 0x70ec 12built 2015 12res 1366x768 12dpi 101
    12gamma 1.2 12size 344x193mm (13.54x7.6") 12diag 394mm (15.5") 12ratio 16:9
    12modes 1366x768
  12Message GL data unavailable for root.
  12Device-1 Intel Sunrise Point-LP HD Audio
    12vendor Acer Incorporated ALI Aspire E5-575G 12driver snd_hda_intel 12v kernel
    12bus-ID 00:1f.3 12chip-ID 8086:9d71 12class-ID 0403
  12Sound Server-1 ALSA 12v k5.15.25-1-MANJARO 12running yes
  12Sound Server-2 JACK 12v 1.9.20 12running no
  12Sound Server-3 PulseAudio 12v 15.0 12running yes
  12Sound Server-4 PipeWire 12v 0.3.49 12running yes
  12Device-1 Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    12vendor Lite-On 12driver ath10k_pci 12v kernel 12pcie 12gen 1 12speed 2.5 GT/s 12lanes 1
    12bus-ID 03:00.0 12chip-ID 168c:0042 12class-ID 0280
  12IF wlp3s0 12state up 12mac <filter>
  12Device-2 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    12vendor Acer Incorporated ALI Aspire E5-575G 12driver r8169 12v kernel 12pcie 12gen 1
    12speed 2.5 GT/s 12lanes 1 12port 3000 12bus-ID 04:00.1 12chip-ID 10ec:8168
    12class-ID 0200
  12IF enp4s0f1 12state down 12mac <filter>
  12Device-1 Lite-On Qualcomm Atheros QCA9377 Bluetooth 12type USB 12driver btusb
    12v 0.8 12bus-ID 1-5:3 12chip-ID 04ca:3015 12class-ID e001
  12Report rfkill 12ID hci0 12rfk-id 2 12state up 12address see --recommends
  12Local Storage 12total 938.97 GiB 12used 34.47 GiB (3.7%)
  12ID-1 /dev/sda 12maj-min 8:0 12vendor Toshiba 12model MQ01ABD100
    12family 2.5" HDD MQ01ABD... 12size 931.51 GiB 12block-size 12physical 4096 B
    12logical 512 B 12sata 3.0 12speed 6.0 Gb/s 12type HDD 12rpm 5400 12serial <filter>
    12rev 5J 12temp 30 C
  12SMART yes 12state enabled 12health PASSED 12on 186d 1h 12cycles 2372 12Old-Age
    12g-sense error rate 440
  12ID-2 /dev/sdb 12maj-min 8:16 12type USB 12vendor SanDisk 12model Cruzer Blade
    12size 7.45 GiB 12block-size 12physical 512 B 12logical 512 B 12type N/A
    12serial <filter> 12rev 1.27
  12SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure?
  12ID-1 / 12raw-size 576.17 GiB 12size 566.06 GiB (98.24%) 12used 34.44 GiB (6.1%)
    12fs ext4 12block-size 4096 B 12dev /dev/sda6 12maj-min 8:6
  12ID-2 /boot/efi 12raw-size 100 MiB 12size 96 MiB (96.00%) 12used 25.2 MiB (26.3%)
    12fs vfat 12block-size 512 B 12dev /dev/sda1 12maj-min 8:1
  12Alert No swap data was found.
  12System Temperatures 12cpu 40.0 C 12pch 40.0 C 12mobo N/A
  12Fan Speeds (RPM) N/A
  12Processes 207 12Uptime 2h 23m 12wakeups 1 12Memory 7.64 GiB 12used 2.5 GiB (32.8%)
  12Init systemd 12v 250 12tool systemctl 12Compilers 12gcc 11.2.0 12clang 13.0.1 12Packages
  12pacman 1218 12lib 335 12flatpak 0 12Client Unknown Client: systemd 12inxi 3.3.15```

```mhwd-kernel -li
Currently running: 5.15.25-1-MANJARO (linux515)
The following kernels are installed in your system:
   * linux515```

```mhwd -l    
> 0000:04:00.1 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

> 0000:01:00.0 (0302:10de:134d) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.12.18               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2021.12.18               false            PCI
          video-nvidia            2021.12.18               false            PCI
    video-nvidia-470xx            2021.12.18               false            PCI
    video-nvidia-390xx            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI

> 0000:00:02.0 (0300:8086:5916) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.12.18               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI```

```mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!```

so did you ran also the update command? did everyhting went well with the updates?
Can you boot now normally into your install, since you mark this post as Solved?

1 Like

Yes my manjaro has restored back it was and also ran the update command first was around 1gb updated closed and came back.
Again there was this 3gb update.

Just now opened my laptop now i cannot find the dual system option(my windows is gone) :sob::sob:

thats ok, dont worry, follow these steps:

  1. boot again into the live usb and enter chroot:
    sudo manjaro-chroot -a
    run update again:
    pacman-mirrors -f 5 && pacman -Syyu
  2. uninstall graphics:
    sudo mhwd -r video-modesetting
    sudo mhwd -r pci video-linux
  3. uninstall kernel:
    sudo mhwd-kernel -r linux515 - if you get some error, cant uninstall kernel, ignore it…
  4. install kernels:
    sudo mhwd-kernel -i linux515
    sudo mhwd-kernel -i linux516
  5. install graphics:
    sudo mhwd -i pci video-linux
    sudo mhwd -i video-modesetting
    we will install nvidia drivers when youre back in your system, just in case…
  6. run these commands:
    mkinitcpio -P
    systemctl reboot
  7. thats it, you should be now able to boot into your system, when everything went well and youre in your system, open terminal and run this command:
    sudo mhwd -i pci video-hybrid-intel-nvidia-prime - this will install the nvidia drivers
  8. reboot your pc

`sudo mhwd -r video-modesetting
Error: invalid use of option: -r/–remove

Usage: mhwd [OPTIONS] <config(s)>

–pci list only pci devices and driver configs
–usb list only usb devices and driver configs
-h/–help show help
-v/–version show version of mhwd
-f/–force force reinstallation
-d/–detail show detailed info for -l/-li/-lh
-l/–list list available configs for devices
-la/–listall list all driver configs
-li/–listinstalled list installed driver configs
-lh/–listhardware list hardware information
-i/–install <usb/pci> <config(s)> install driver config(s)
-ic/–installcustom <usb/pci> install custom config(s)
-r/–remove <usb/pci> <config(s)> remove driver config(s)
-a/–auto <usb/pci> <free/nonfree> auto install configs for classid
–pmcachedir set package manager cache path
–pmconfig set package manager config
–pmroot set package manager root`

should i ignore this one also?

try again with this without the sudo:
mhwd -r video-modesetting
pay attention to the command, write it exactly it is here
if it still doesnt work, ignore this command and continue with the others

still the same thing my windows 10 option is not showing, when i switch on my laptop it directly opens manjaro :sweat:

so you run all the commands? and now you can boot into manjaro?

Yes i can run manjaro but my windows 10 gone missing

ok then open terminal and run this command:
sudo update-grub
and copy the formated output here
then reboot

sudo update-grub  :heavy_check_mark:
[sudo] password for vivi:
Generating grub configuration file …
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.16-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.16-x86_64.img
Found initrd fallback image: /boot/initramfs-5.16-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.15-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.15-x86_64.img
Found initrd fallback image: /boot/initramfs-5.15-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings …
Found memtest86+ image: /boot/memtest86+/memtest.bin