Is it possible to remove the margins from the right side of the KDE Plasma panel?

My first install was Ornara and there weren’t margins in the panel. I liked that because I formatted the date to include the day and the month as words, and the time and date looked big. I know some people like to reduce the panel height. I used to be one of them, but the time and date size was one of the reasons for me to change my mind.

Now, in the edit mode you see margins which make the time and the date aligned with the icons. Makes a lot of sense aesthetically, but I got used to bigger time and date. Is it possible to remove the margins?

From my inxi report:

  Kernel: 5.10.61-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=f30fc803-7236-483f-9d05-9216ccceb355 rw quiet apparmor=1 
  security=apparmor resume=UUID=abeb2bd7-6c98-4ca2-9b68-6f5e2cb5f618 
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Processes: 267 Uptime: 1h 39m wakeups: 1 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: N/A Packages: pacman: 1257 lib: 356 
  flatpak: 0 Shell: Zsh v: 5.8 default: Bash v: 5.1.8 running-in: konsole 
  inxi: 3.3.06 

I’m not really sure what margins you are talking about. Can you post a screenshot? I don’t see how the time and date could be misaligned as everything is on one line by default.


The time and the date stay within these blue things. I want to give time and date space to breathe.
Time and date get bigger when I increase panel height, but I don’t want to do it like that.

I don’t get it, is this a new Manjaro install? Also, where is the date?
Did you modify the Panel used (Plasma Style in Appearance settings)? Seems like it to me, I mean this doesn’t look like a default Panel to me but maybe that’s something new in the last ISO, I’m not sure.

The margins are only seen in the Edit panel mode, but they are clearly affecting the date.

margins 2

Yeah, it’s the edit mode… Could you post a screenshot in the standard mode to see if there is a problem with date formatting?

If I understand you dislike the edit mode display, I guess it’s more a KDE upstream (or theme related?) “issue” rather than a specific Manjaro one.

I don’t have these bars/margins when in edit mode. I tried various Panels and they all act the same, without these margins.

What happens if you configure the tray icon thing (right click the up arrow in tray) to enable the Auto mode instead of forcing small icons?

What is the Panel height? I noticed under 40px on my side the tray icons get way smaller.

I enabled Scale with Panel height. The icons became a bit bigger, but the date remained the same.

Compare the date and desktop icon size here: Linux overview | Manjaro 21.0.7 KDE Plasma Edition - YouTube

That is what I want. Taller date.

This is just the padding in plasma panel. You can drag whichever widgets out of the padded area (drag the widgets to the left) and they will be bigger.

After dragging date & time to the left of padded area:

AFAIK, the old Breath2 theme (which was there on Ornara and is in Pahvo too) doesn’t have the padding.

1 Like

Thanks. I didn’t think of moving the clock. That does solve the size problem, although I would prefer to have it in the default position.

I am indeed running Breath2 2021, but switching to the old Breath didn’t change the clock size.

EDIT I didn’t think this was theme-related, but I tried the Oxygen theme and the date is big in it. I’ll consider switching to Oxygen, although I like Breath2 2021.

EDIT 2 The closest I got to what I wanted is this: System Settings > Appearance > Global Theme > Plasma Style > Breath Dark. I’m not completely satisfied (I’m not sure I’m digging the active window highlight in the panel and the icons in the panel).

I still think I might edit Breath2 2021 in a file somewhere (plasma-org.kde.plasma.desktop-appletsrc) in such a way as to get exactly what I want.

Tried to move it on the other side? Tried to move everything out of this “margin area”?

I think this is a new feature with Breath themes, in Edit mode I think you have more settings about that if you click the cog wheel on the right side. No it is not the same thing, but still there are new features with Breath themes Panel. Not really sure what you were referring to :\

That’s right, @carpet , if you move every thing out of the padded area, there will be no padded area to see. :slightly_smiling_face:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.