Is it possible to install WPS Office in Manjaro?

AUR builds return “==> ERROR: wps-office-stable is not available for the ‘aarch64’ architecture.”

snap in konsole returns “error: snap “wps-office” is not available on stable for this architecture (arm64) but exists on other architectures (amd64).”

I’ve downloaded both the deb and rpd files from the wps website but can’t figure out how to install them. (Admittedly, this may have something to do with my relative naivety in using Linux.)

This is my first day using Manjaro, which came on a new laptop (Pinebook Pro) and WPS is one of the first programs I want to install.

Nothing to do with manjaro really … those packages are made for x86_64.
(not ARM)
You can try to modify the PKGBUILD from the AUR to include your architecture.
I have no idea if it will work.

( edit - from a quick search it looks like WPS does not support ARM … though they do release a separate thing for android … which assumedly supports ARM … … odd …)

Since WPS office is not open source and they only provide builds for the 64-bit x86 architecture, I think you’re out of luck. You’d need some kind of x86_64 emulation/virtualization.

Although they have an Android application, so you might be able to get that working with Anbox, but I don’t think it has as many features as the desktop variant.

WPS Office is only available for x86_64 via their official DEB & RPM packages, unfortunately. Also, the wps-office-stable AUR package has been out of date for well over a year.

Pinned comment on wps-office AUR:

[ATTENTION] The new international version ( removed zh_CN support, login, and some other functions. If you still want full functions, or you want aarch64 support, you may need the Chinese version from here: AUR (en) - wps-office-cn

And indeed, the PKGBUILD of wps-office-cn indicates aarch64 support.

1 Like

Of course we should have looked at the AUR page :laughing:
Good catch.

I’ll try downloading the Chinese version and adding an English mui.

Well, there’s two: wps-office-stable (which he tried to install) and wps-office. The former is out of date and unmaintained. I orphaned it and submitted a request to merge the two.

Have you tried this method?

1 Like

You could use debtap as a LAST RESORT to convert deb files, and then install them as local files.

As an aside, Libre Office seems to be more ‘compatible’ with MS Office as you can save MS Office files in the latest format. I think WPS saves files as an older version, which open in compatibility mode in MS Office.

You may also want to install/copy MS fonts into your Manjaro fonts database for even more compatibility with MS Office to avoid substitute fonts being used.

It works! Thanks!

Last I checked, WPS offers both .doc and .docx.

Thanks, done.


EDIT: Let me try with a file.

1 Like
  1. Just saved a .docx file in the latest WPS as a ‘Microsoft Word Document’ (from the save drop-down menu.
  2. The file opened in MS Word 2016 in [Compatibility Mode]
  3. SAVE AS (in Word 2016) pops-up that the file ‘will be upgraded to the latest file format’.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.