Is it possible to have Davinci Resolve on Manjaro?

Hey,

quite new to Linux and to Manjaro. Been using it for almost a year now.

I would absolutely loooove to be able to run Davinci Resolve on it, but so far was unable to.
My laptop has AMD Vega integrated GPU.
The problem is Davinci officially supports only CentOS.

I’ve tryed both AUR and manual installation, kernel regression and also been using davinci resolve checker to check if it can run

The best I could manage is to get it running but the videos in it couldn’t play, even after transcoding them to acceptable codecs.

Sorry for not posting logs and errors,
I’d just like to know if someone managed to run it on similar config (AMD GPU), and how.

I’m a basic Davinci user, didn’t use fusion much, so am happy with the basic HW that I currently have.

manjaro does not deliver the non-free amd-codecs per default. you’ll have to install them manually.

2 Likes

@Olli TY for quick reply!
What’s the safest way to get them, plz?

Davinci Resolve seems to be available from the AUR, if that’s an option for you; but remember, the AUR is not officially supported by Manjaro (or Arch), so you’ll likely be on your own in terms of support.

pamac build davinci-resolve
pamac build davinci-resolve-studio

I used Davinci Resolve Studio for a while – on KDE, using Wayland and amdgpu – I don’t recall any major difficulties with it.

1 Like

@soundofthunder did you also have those AMD codecs?

TY all for the help, I’ll try it over the weekend, and maybe ask for more help :wink:

Many plugins pulled in and built as dependencies. I don’t recall whether I needed any specific codecs; although, if I did, it was likely I already had them installed for other purposes.

1 Like

Plz, what’s the best way to install the AMD codecs, link to forum post or command?

Please see information available at:

Note that this is possibly unsupported by Manjaro.

However, there are related threads to be found by searching the forum. You might try non-free codecs as the search term, for example.

Cheers.

1 Like

@soundofthunder I’ve tried, it seems that for these mesa codecs I’d need to switch to unstable Manjaro branch. How safe would that be?
The https://nonfree.eu contains only unstable stuff, and I couldn’t download he /etc/pacman.d/mesa-nonfree.pre.repo.conf … it’s a 404 html doc

Arch is always “unstable” - yet it works. :man_shrugging:

Open it in a browser - read it.
Just click the link.
It tells you how to use it.

2 Likes

How confident are you with Linux generally?

On the Unstable branch you should expect things to break; as they no doubt will. If you already find yourself lost, not knowing how to fix things in the Stable branch, then no, don’t even think about Unstable.

But… you still want those non-free codecs, and this is the only way you can have them on Manjaro. You need to either find another alternative to the non-free codecs, or use the free codecs, or switch to Unstable. Only you can decide which is practical for you.

I haven’t used DRS since last year (before the non-free codecs were removed) so I don’t know how well the free codecs work. I’d have expected they should be better than what you describe though.

Cheers.

1 Like

@Nachlese sry but the link in 404 page just points to docs of github itself.
As I see it, there actually exists no such Mesa non-free stable version of AMD codecs,
only unstable, and I haven’t got that much knowledge or time to tinker with the Manjaro unstable version.

if you’re not willing to spend time on “tinkering” with an rolling-release then use a distro that provides your needs (in this case CentOS).
it’s pointless to say any more.

It’s a regular page with descriptions - and with links to pre-built packages - it is not a 404.

I cannot help with that.

1 Like

sudo sh -c "curl -s https://nonfree.eu/unstable/ > /etc/pacman.d/mesa-nonfree.pre.repo.conf"

That command requires that you have curl installed in your system.

sudo pacman -S curl

It’s not meant as a typical download link; it should be used only as directed.

Furthermore, when you run the command it’s not expected to give any feedback;
however, you can see the direct result:

cat /etc/pacman.d/mesa-nonfree.pre.repo.conf
[mesa-nonfree]
SigLevel = Optional TrustAll
Server = https://nonfree.eu/unstable/$arch

Again, this is useless in Stable branch;
and should be removed again, if you were simply playing with the commands:

sudo rm /etc/pacman.d/mesa-nonfree.pre.repo.conf

Cheers.

1 Like

Ok. sorry if I’m being noobish with these questions, I don’t want to break the system :slight_smile: to get a black screen with possibly setting up something wrong with video driver.

Did that, installed (all) mesa packages.
Installed davinci with from AUR pamac build davinci-resolve

When I run it with:
/opt/resolve/bin/resolve

I get
“DaVinci Resolve could not initialize OpenGL. Please ensure
that the latest graphics drivers are installed.”

No idea about your blackscreen problem right now, but i have some other points for you.

Im coming a little bid to late to the party :partying_face:

  1. I always recommend for new user’s to use Timeshift (Rsync) on a external HDD, when you mess around with your OS, for a quick and fast rollback function, to have always a working OS (just in case).

  2. About the AMD Video Encoding Topic, im actually not 100% sure if you really need this AMD HW Acceleration Video Codec support that required to switch to unstable branch.

  3. Because when i do Video Encoding with Shotcut, i evade nvidia hardware acceleration support… because of the decreased quality, i use the software encoding option which takes longer to process but for my use case it works.

Anyways, since im using a nvidia GPU (maybe AMD HW Codec doing a better job) and since im not doing video encoding with davinci, it could be irrelevant to you.

1 Like

I believe it’s needed for decoding, for playing videos during editing phase, not for encoding during rendering the final video result.

What should I do about the OpenGL missing?
I’ve heard of progl, but didn’t make it functional before.

Any comments?
I believe this is the last piece of the puzzle missing to run Davinci on AMD laptop.