Is it possible to force loading pcc_cpufreq?

I want to like to test a different cpu driver, for my cpus, to track down an issue I have.
On another system I have (slackware based) I noticed that the cpu driver that is loaded is pcc_cpufreq and the issue I’m tracking down doesn’t show.

The default driver that is loaded is intel_pstate, I disabled it in grub config as a kernel parameter (intel_pstate=disable). On next reboot acpi_cpufreq is loaded and I can blacklist this too.
On next reboot I have no driver loaded, and if I try to manually load pcc-cpufreq I have:

[root@tower tower]# modprobe --verbose --force pcc-cpufreq
insmod /lib/modules/5.4.80-2-MANJARO/kernel/drivers/cpufreq/pcc-cpufreq.ko.xz 
modprobe: ERROR: could not insert 'pcc_cpufreq': Key was rejected by service

How to load pcc_cpufreq?

Driver is available in /lib/modules/5.4.80-2-MANJARO/kernel/drivers/cpufreq/ and SpeedStep is enabled in bios.

[root@tower cpufreq]# ls
acpi-cpufreq.ko.xz	    cpufreq_ondemand.ko.xz   pcc-cpufreq.ko.xz
amd_freq_sensitivity.ko.xz  cpufreq_powersave.ko.xz  powernow-k8.ko.xz
cpufreq_conservative.ko.xz  cpufreq_userspace.ko.xz  speedstep-lib.ko.xz
cpufreq-dt.ko.xz	    p4-clockmod.ko.xz


The link doesn’t say anything about what I asked…