Is it necessary to shrink C drive for installing Manjaro Linux?

I have 3 drives
C - windows 10 boot
D - Logical drive
E - Primary partition
I have Legacy bios
I tried shrinking from E primary partition and got unallocated space where I wanted to install Manjaro KDE Plasma. But when i started installation it gave me error that “cannot create partition”
is it related to shrinking space from drive other than C??
Im stuck here dont know what to do

can you boot on USB iso manjaro
open a terminal (kconsole) and a browser on this topic
and report

inxi -Fza
sudo parted -l 
sudo efibootmgr -v

Can you please ask in layman terms?
I am trying to install from bootable usb if that helps
didnt get the terminal and browser part

[manjaro@manjaro ~]$ inxi -Fza
  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us 
  tz=UTC misobasedir=manjaro misolabel=MANJARO_KDE_2021 quiet 
  systemd.show_status=1 apparmor=1 security=apparmor driver=free 
  nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: Dell product: Latitude E5520 v: 01 
  serial: <filter> Chassis: type: 9 serial: <filter> 
  Mobo: Dell model: 0KCT5J v: A02 serial: <filter> BIOS: Dell v: A14 
  date: 12/26/2013 
  ID-1: BAT0 charge: 65.1 Wh condition: 65.1/86.6 Wh (75%) 
  volts: 12.6/11.1 model: Sanyo DELL FKYCH33 type: Li-ion 
  serial: <filter> status: Full 
  Info: Dual Core model: Intel Core i3-2330M bits: 64 type: MT MCP 
  arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 
  microcode: 2F L2 cache: 3 MiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 17564 
  Speed: 2185 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 2185 
  2: 2195 3: 2094 4: 2180 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, 
  SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: 
  conditional, IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 2nd Generation Core Processor Family Integrated 
  vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0116 
  Device-2: Sunplus Innovation Laptop_Integrated_Webcam_FHD type: USB 
  driver: uvcvideo bus ID: 1-1.4:3 chip ID: 1bcf:280b 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: intel 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 2390x768 s-dpi: 96 s-size: 631x203mm (24.8x8.0") 
  s-diag: 663mm (26.1") 
  Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 102 
  size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
  Monitor-2: VGA1 res: 1024x768 hz: 60 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) 
  v: 3.3 Mesa 20.3.1 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1c20 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi 
  v: kernel port: 8040 bus ID: 02:00.0 chip ID: 8086:0082 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Broadcom NetXtreme BCM5761 Gigabit Ethernet PCIe 
  vendor: Dell driver: tg3 v: kernel port: 8040 bus ID: 0a:00.0 
  chip ID: 14e4:1681 
  IF: enp10s0 state: down mac: <filter> 
  Local Storage: total: 328.17 GiB used: 205.7 MiB (0.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST320LT020-9YG142 
  size: 298.09 GiB block size: physical: 4096 B logical: 512 B 
  speed: 3.0 Gb/s serial: <filter> rev: DEM1 
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Generic 
  model: Flash Disk size: 30.08 GiB block size: physical: 512 B 
  logical: 512 B serial: <filter> rev: 8.07 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw size: N/A size: 2.8 GiB used: 205.7 MiB (7.2%) fs: overlay 
  source: ERR-102 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 72.0 C mobo: 45.0 C sodimm: SODIMM C 
  Fan Speeds (RPM): cpu: 3788 
  Processes: 228 Uptime: 4m wakeups: 2 Memory: 3.74 GiB 
  used: 1.73 GiB (46.2%) Init: systemd v: 247 Compilers: gcc: N/A 
  Packages: pacman: 1264 lib: 375 flatpak: 0 Shell: Bash v: 5.1.0 
  running in: konsole inxi: 3.2.01 
[manjaro@manjaro ~]$ sudo parted -l
Model: ATA ST320LT020-9YG14 (scsi)
Disk /dev/sda: 320GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type      File system  Flags
 1      368MB   77.3GB  76.9GB  primary   ntfs         boot
 2      77.3GB  77.8GB  553MB   primary   ntfs         msftres
 3      77.8GB  162GB   83.9GB  extended               lba
 5      77.8GB  162GB   83.9GB  logical   ntfs
 4      162GB   289GB   127GB   primary   ntfs

Model: Generic Flash Disk (scsi)
Disk /dev/sdb: 32.3GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      3226MB  3230MB  4194kB  primary               esp

[manjaro@manjaro ~]$ sudo efibootmgr -v
EFI variables are not supported on this system.

He wanted you to provide information so that we can assess the situation.
Boot from the USB that you want to use to install Manjaro.
Open a Browser - log into this forum, so that you can post the needed feedback.
Open a terminal and run the commands, one after the other, Highlight the output and copy/paste it here as a response.
Please format the output with the “preformatted text” button (</>) in the menu
by highlighting it again and then “pushing” that button.

check now

When you are referring to drives - are you referring to the number of disk devices or to the number of partitions on the only disk device?

When you are using BIOS/MBR you can only have 4 primary partitions or 3 primary partitions and one extended partition which can hold several smaller partitions.

I vaguely remember how the Legacy MBR partition table has pestered my life and MBR will continue pestering computers for years to come.

I have one hard disk and it has 3 partitions
C - windows boot
D - Logical
E - Primary

Hi @abdullahdurrani ,

I’ll try to explain this better, but I’m afraid I won’t be able to do more than that, almost time for lunch here so I might be back later.

This you get, since you booted up, into Manjaro.
(This is the Live ISO that you use to install Manjaro.)

  1. Open the launcher, or Start menu as it’s called in Windoze.)
  2. Type in konsole and open konsole. Konsole is the KDE Teerminal applivation that allows you to run commands directly on the computer and provides text only feedback. It’s text only.
  3. Open the browser, Firefox IIRC, and browse to this topic.
  1. Run each of those lines in the previously opened konsole (terminal). Select the (text) output and copy it.
  2. Return to the browser and the opened page here. Reply to this topic.
  3. In the reply, provide the command and the output for the command (Paste the text copied text above.) But don’t submit it in plain text, wrap the pasted output in 3 backticks (```) for better display formatting.
  4. Submit the reply.


You might want to get familiar with concepts such as “copy” and “paste”, the “terminal”, a “command” and the "output" before going further, as this will save you much hair pulling, frustration and tears.

Hope this helps.

You cannot create more partitions than you have which is your problem.

The only place you can add a partition would be your third extended partition - this is the only one which hold extra partitions.

This is by design and the limit of MBR.

If it is possible - you can move data from partition on your extended partition (5. partition). Move data to the fourth partition - then you remove partition 5 - then partition 3.

When this is done you can use the now released space to create a 4. primary partition and install Manjaro onto the new partition.

Remember to install the bootloader to the device (/dev/sda) not the partition(dev/sdaX).

so you meant to say I should delete the logical partition?
5 77.8GB 162GB 83.9GB logical ntfs
this one?

Yes - both the logical partition and the extended partition holding the logical partition.


Deleting a partition also deletes ALL data on it.

(You guys seem to have it all in hand, so I’ll keep my yap shut and stay out from here on.)

2 77.3GB 77.8GB 553MB primary ntfs msftres
what is this partition?
It has only 500mb size.

I don’t know - msftres is short for Microsoft reserved - so a guess would be a system rescue partition holding tools or something like it - don’t remove it.

okay thanks

Ah thanks I just got confused there for a sec with the report thing xD

1 Like

okay i deleted the logical drive and it is showing free space but now when i tried installing Manjaro.
I get error when i make partition for linuxswap that i cannot create new partition because i have 4 primary partitions :expressionless:

Then don’t make a swap partition - instead you make a swap file inside your new primary partition.

Read more on swap on the wiki → Swap - Manjaro

installed it finally Thanks for help