Invisible Smb4k icon on KDE menus

It’s an annoyance hardly worth chasing down, but does anybody know why Smb4k’s menu icon doesn’t appear? Doesn’t matter which of the four KDE menus (dashboard, launcher etc.) or if the theme is light or dark. The icon appears in panels, the desktop and even the Menu Editor, just not the menus themselves.

I was hoping the next Smb4k update would fix it but that was today and no dice.

I don’t use it, but how did you install that and what are the contents of its .desktop file?


I found these files that would result in a big dump that probably isn’t pertinent.


But “.desktop” rang my bell. I should have tried new users before posting. For them the icon shows up in menus. That narrows it down a bit.

Solved. A while back, once I got Smb4k working with /mnt/smb4k as its mount point, I inadvertently left it set to the default /home/user/smb4k. Once it was changed back to /mnt/smb4k and /home/user/smb4k was deleted, the icon started showing up in menus. Favorites is favored again!

Was this a case of what you were referring to here? If I not I suppose two different mount directories conflicted.

Therefore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)


Exactly! :grin:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.