Invisible cursor in a game


When i’m trying to play one Steam game (Passpartout: The Starving Artist), my mouse cursor becomes invisible for the game but stays visible for Manjaro itself. It does not matter whether the game is windowed or fullscreen. I noticed that Arch and Manjaro has had previously some oddities with vanishing cursor so probably this has also something to do with it?

I was about try to edit xorg.conf for “HWcursor” setting as suggested some pages but realised i don’t have such a file at all (/etc/X11/ or /xorg.conf.d) so that was end of this storyline.

Anything i could try? DE is Xfce, and graphic card radeon hd (not integrated), drivers are defaults.

Hi and welcome to the forum :+1:

Please see:

The file you meantioned is not used anylonger with the current versions of Xorg-Server, those pages you must have read must have been very old.
The current version uses snippets inside /etc/X11/xorg.conf.d/ you could try to place a config there.

Thanks for the reply!

Yes, those threads i read were some years old but maybe relating to this, don’t know for sure.

in /xorg.conf.d/ there’s only one file “00-keyboard.conf”. I think not related to this. But i don’t have knowledge could i create my own file that system uses.

To be more exact about the problem: I open the game, there is cursor in the begining but it becomes invisible after placing painting on table, and it never appears again. But the mouse’ functionality is there, just no more graphical pointer (basic pointer, there’s painting tool-pointer while painting), have to act in blind. If game is in windowed mode, i have cursor in the Manjaro itself, like i can go to OS menu with cursor but if i try to move it over game window there is no cursor.

Then it is a game-specific issue…
The best place would be the steam community in that case i think :woman_shrugging:
Or something with “Compositing” settings of your window manager in combination with your GPU.

“Snippets” mean separate config pieces, so you can try…

Developer checked my game-logs and logs were okay no errors related to this.
But he suggested it could be operating system specific issue.

Maybe game isn’t totally compatible with Manjaro, or Manjaro with the game :sweat_smile:
The game should support Linux though…

I don’t have skills to try to test around things. But i did try Composing feature but unfortunately it didn’t bring relief thought didn’t try every possible combination yet from Compositor. Just mostly Enable/Disable the Compositing.

When i find time, i may try if i could run Steam and the game on another distro’s live-media (prob. ubuntu or mint), to see if there’s cursor.

Yeah, i don’t know would the silent game community have some help for this, at least search didn’t bring up any related issues in there. So tried to ask here where people at least know about Manjaro.

Or maybe it is some how just MY-system specific issue with the game…
Though i have pretty default settings everywhere as i’m not yet much familiar with Arch-based distros :grin:

This problem was solved by developer released patch for invisible cursor on Linux platform. The game is working fine now :grinning:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.