"Invalid URL" with manjaro-tools

manjaro-tools

#1

Hey,

I want to make a custom Manjaro build again. I already did it succesfull last year, so I know the basic concept.
But now that I tried again, I run into a different problem:
I can’t start the build process, because of a connection problem:

sudo buildiso -p xfce

:: Synchronizing package databases…
error: failed retrieving file ‘core.db’ from mirror.netzspielplatz.de : SSL certificate problem: unable to get local issuer certificate
… and so on

My normal updating pacman etc. works without a problem. I tried setting a different mirror, but apparently the mirrorlist for manjaro-tools is different than for my normal manjaro system… now I found the list in:

/etc/manjaro-tools/manjaro-tools.conf
And I used a different mirror

build_mirror=ftp.tu-chemnitz.de/pub/linux/manjaro

Only to get the same error.

I am currently working my way through:


but it seems all related to the normal pacman update?
And this all works for me.
Any ideas?
Or should I mess more with my keyring etc.

Oh and in general. I just freshly installed this manjaro system with the latest official build, so I didn’t mess with anything so far.


#2

This is an issue with the server’s SSL certificate (try loading the URL in a browser). You (we) can’t fix this.


#3

I can do so without problems


#4

Yup, it’s fixed. And you only had to wait for an hour or so.


#5

PS: The above is a no-no. Don’t use sudo with buildiso, buildpkg, makepkg or any AUR helper.


#6

PS: The above is a no-no. Don’t use sudo with buildiso, buildpkg, makepkg or any AUR helper.

Ah yes, I only tried sudo as a standard error-solving approach.
(even though I know it is not allways the smart way …)

But I still get the same error
(and so far nothing of the other thread worked. I tried all the recommended methods)


#7

Ok, I tried everything I could think of.
Still the same:
normal update - works
accessing the server directly - works

buildiso -p xfce

fails with

:: Synchronizing package databases…
error: url ‘ftp.tu-chemnitz.de/pub/linux/manjaro/stable/core/x86_64/core.db’ is invalid
error: failed to update core (invalid url for server)


#8

Server address

You need to supply the full internet address

build_mirror=ftp://ftp.tu-chemnitz.de/pub/linux/manjaro

or

build_mirror=http://ftp.tu-chemnitz.de/pub/linux/manjaro

or

build_mirror=https://mirror.netzspielplatz.de/manjaro/packages

manjaro-tools.conf

Do not modify the files in /etc/manjaro-tools but copy the folder to your home

cp -R /etc/manjaro-tools ~/.config

Modify the file ~/.config/manjaro-tools/manjaro-tools.conf

iso-profiles

If you want to modify an iso-profile copy the folder to your home folder

cp -R /usr/share/manjaro-tools/iso-profiles ~/manjaro-iso-profiles

Modify your copies as needed. To make buildiso use your modified versions add a file in your local manjaro-tools folder and name it iso-profiles.conf

touch ~/.config/manjaro-tools/iso-profiles.conf

Add the following content matching your local profiles dir

run_dir=/home/$USER/manjaro-iso-profiles

#9

Oh, also war es doch ein temporärer Fehler …

Danke ! :grinning: