Invalid signature for linux-surface repo

Environment

Manjaro 21.2.0
Surface book 2
KDE Plasma 5.23.4 (Same issue with GNOME in a separate partition)
Kernel version 5.15.11-arch2-1-surface (64 bit)

Issue

When I try to update or install a package:

$ yay -S <package-name>
error: linux-surface: signature from "linux-surface" is invalid
error: database 'linux-surface' is not valid (invalid or corrupted database (PGP signature))
 -> error installing repo packages

Same issue on Manjaro 21.2.0 GNOME with pamac update. Additionally, I manually allowed the linux-surface repo to be used without error checking as below, and that failed. Now the Manjaro GNOME install does not boot up:

[linux-surface]
SigLevel = Never
Server = https://pkg.surfacelinux.com/arch/

Third-party kernels and repos are not supported. The repo certificate may have expired.

See the setup guide: