Invalid password

Not sure this is the correct category, but my password (on the account with admin authority) was rejected as invalid (I’m sure I typed it correctly and caps were not on). I logged in ok with another account (no admin authority). Did ctrl-alt-f2 and tried to log in, didn’t work. Account got locked, waited 10 minutes, account got locked, waited 10 minutes. Tried logging in again (with same password) and it worked. So, question is, has my system been compromised? Why would this happen? I don’t feel comfortable just letting it go since I can log in now. Something unacceptable happened. Any clues?

No, it could be fairly some delayed background process, if it works after some time.

I would suggest to reset the password and see if that fixes the problem. Since you logged in, that should do it:

sudo su
passwd root
passwd zeddie

Just type the same or a new password.

Thanks for the suggestion. My session timed out, and now I can’t log in again, even in a console. If and when I can log in again, I will try changing the password. I tried a different keyboard, not that. Wondering if it could be a disk problem, but the other userid I try works everytime. I’m using it now.

Just a little trick:

  1. Boot your system to the grub menu. ESC
  2. Edit the menu entry with E
  3. Add at the line starting with linux this:
  1. Type F11 to boot.
  2. Now at the bash session remount the root filesystem writeable:
mount -n -o remount,rw /
  1. Overwrite any password you like:

Sure, you must have physical access to the machine to change it like that.


When you get back on, check the journal/log via

journalctl -b 0                  # by boot; 0=last, -1, -2, -3

journalctl --list-boots

journalctl --since="2022-04-11"  # by date

Does the command last or lastb show the failures, and perhaps why?

Boot up a Manjaro’s Live ISO, and open up an editor and type some characters, your passwords, does it show properly?

I did an advanced search (click icon at end of search text box) for password status:solved in:title in this forum. Some of the solutions:

  • reboot
  • are there any .pacnew files in /etc. ( DIFFPROG=meld pacdiff)