Invalid passphrase on boot in grub, but passphrase is correct

Hey guys

I got a new HDD, created partition table msdos and formatted all the partitions with luksformat and ext4 and rsynced my original backup partitions right back into the new partitions.

I updated the new UUIDs in grub, crypttab and fstab and reinstalled mbr with grub-install /dev/sda then did mkinitcpio -P and update-grub.

Everything fine, booting in live USB I can decrypt and mount all partitions.

However, on reboot, GRUB asks for a passphrase for the right partition (root), upon entering passphrase grub says the passphrase is invalid, and the disk can not be found. Then it sends me to grub rescue>

How do I troubleshoot this headache?

check your bios settings for efi-boot.

Try again with the mkinitcpio command as last, because the re-created grub config needs to be put inside the initrd :wink:
Disclaimer: i’m neither a fan nor a user of Grub…

When I had that issue it was due to the keymap changing for some reason at the point where I’d unlock the device, but it was fine when I’d chroot into the disk because the keymap was “normal” on the live USB.

For me it was where I had an @ in the decrypt password, instead of the shift-@ key I had to use the US shift-2 keyboard keys to open LUKS at boot.

Ok, so I just went ahead and just freshly installed manjaro on the first partition, fixing mbr.

Then I deleted everything in the first partition, and rsynced everything from the backup into the first partition.
Then updated the UUIDs in grub, crypttab and fstab
and then mkinitcpio and grub-install, update-grub and the thing was working again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.