Invalid File Permissions file could not be saved

I am trying to install programs and games onto my extra storage devices/drives both ssd and hdd but I keep getting this message:

Invalid Save Permissions: The file could not be saved because you don’t have the proper permissions. Choose another save directory.

How do I allow my system to save and install to my extra storage devices/drives?

If someone could give me a detailed walk-through on what commands to enter into the terminal I’d be very grateful.

What I’ve learned from reading other posts so far:

  • chmod has to be used
  • (xrw) executable, readable, writable might need to be used
  • ext4 formatted hard drives have this issue due to a security feature in Linux. My drives need privileges that it obviously doesn’t have right now.
  • I have to set something to 775

I’m new to Linux so I’m going through quite the learning curve. Tough putting the puzzle pieces together without formal training on Linux which I’m working on.

I just tried chmod 775 /run/media/rogan/Games/ and it came back with operation not permitted. Is this because I didn’t use sudo? I recently read on another forum that you shouldn’t use sudo for this as it will create a security issue. Is this true?

I just tried it with Sudo and it still didn’t work.

you probably want to own the mount point first with

sudo chown -R user:user <path>
then change the permissions
sudo chmod -R 775 <path>

there is also a great solution over here on the arch forum about setting up a storage group for disks if you want to work with the least privilege.

Edit: fixed typo in chown command, sorry about that.

1 Like

Thank’s Akin. I will play around with this for a bit and see if I get. I’ll keep you posted.


Now this is what I’m talking about! THANKS. :smiling_face_with_three_hearts:

1 Like

I tried owning the mount point by playing with different variations of the command you provided and this is what the terminal came back at me with.

Please note? (Games) is what I named my drive/storage device using the Gparted app.

sudo chown rogan:rogan -R /run/media/rogan/games/devnvme1n1p1 —no such file or directory
sudo chown rogan:rogan -r /run/media/rogan/games/devnvme1n1p1 —invalid option r
sudo chown rogan:rogan -r /run/media/rogan/games(/devnvme1n1p1) —syntax error
sudo chown rogan:rogan -R /run/media/rogan/games/ —no such file or directory
sudo chown rogan:rogan -R /run/media/rogan/games —no such file or directory

Unix/Linux filesystems are case-sensitive. This applies to folders, files, and “devices”.

Secondly, why are you appending more stuff beyond the actual root path for your drive?

This is supposedly the path to the external drive:

Don’t keep adding to it like in some of your examples above.

Any idea why the command sudo chown rogan:rogan -r /run/media/rogan/games —invalid option r comes back with invalid option r? Knowing this would help me move forward.

Because as the error message states, -r is an invalid option. It’s not even in the chown manpage or tutorial. You introduced -r yourself.

@akin2silver there’s a typo in your earlier post. :warning:

(Happens to the best of us.)

1 Like

I’m just following akin2silver’s advice. Any resources you can link me to learn how to take ownership of a mount point?

Oh, okay, that is awkward.

@akin2silver should edit their post. -r is invalid.

Besides, the “flags” need to come before the rest of the command.

  1. The -R must be placed before the user:group parameter.

  2. A device special file is not a directory and is rarely ever to be used by regular users. It has no place in the directory path, and its permissions should never be changed. Besides, that wouldn’t do you any good anyway, because the device special files are stored on devtmpfs, a memory-based filesystem created by the kernel at boot time. Therefore, upon the next boot, the permissions would be set back to their defaults anyway.

  3. UNIX is case-sensitive. FileName.txt is not the same thing as filename.txt.

So it should be sudo chown -R rogan:group /run/media/rogan/games? What is a group and how can I find out what to put in for the group?

That’s useful to know. Thank you.

No, because higher up you said… :arrow_down:

… to which @winnie remarked… :arrow_down:

As I posted higher up… :arrow_down:

You didn’t read it, did you? :face_with_raised_eyebrow:

By the way, if that other filesystem is NTFS, then changing the permissions on the mountpoint isn’t going to do you any good.

NTFS does not store or even recognize POSIX permissions. Instead, the permissions have to be faked by way of the mount options, and once the filesystem is mounted, the fake permissions cannot be changed. The filesystem would need to be remounted with different fake permissions.

I understand that Linux commands are case sensitive. I try upper case and lower case because I like learning by trial and error. Helps me learn quicker.

No I didn’t read that tutorial because from my understanding I have to take ownership of the mount point first. I’d like to learn how to do that before I move onto the next step. So I read the article on mount points.

I understand NTFS formatted drives cause issues on Linux which is why I reformatted both of my drives to EXT4.

This is exactly why I recommend not relying on automounting by systemd/udisks2, but to set up a static mountpoint for the “external” filesystem inside your ${HOME} by way of /etc/fstab. Any directory you create inside your home directory — without using sudo — is always going to be owned by you and have the correct permissions.

Learning only by trial and error will lead you into :fire:

The right way is: Learning by reading documentation


  • manpages
  • arch-wiki
  • manjaro-wiki
  • previous posts in forum
  • What others reply to your question

Ignoring good advice will lead to … :boom: