Introducing: manjaro32.org

i686
manjaro32

#62

A clumsy workaround might be to download the packages due to an upgrade manually with wget.


#63

Try refreshing the key first :

sudo pacman-key --refresh-keys Andreas Baumann

If refreshing not worked, manually sign it (therefore trust it) :

sudo pacman-key --lsign-key Andreas Baumann

#64

Nice, that helped me to perform full upgrade.

In same time that Maximum file size exceeded error for core, extra and community repositories are intact. Installing from manjaro32 repo works. Previous full upgrade from all repositories went well too.

When attempted to install Orage or Pacaur using Pamac, I get different error:

Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading orage-4.12.1-3-i686.pkg.tar.xz...
Checking keyring...
Checking integrity...
Error: orage: signature from "Evangelos Foutras <evangelos@foutrelis.com>" is invalid

Failed to commit transaction:
invalid or corrupted package (PGP signature):
Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading expac-8-1-i686.pkg.tar.xz...
Checking keyring...
Checking integrity...
Error: expac: signature from "Dave Reisner <d@falconindy.com>" is invalid

Failed to commit transaction:
invalid or corrupted package:

Using
# pacman-key --refresh-keys Evangelos Foutras
or
# pacman-key --lsign-key Evangelos Foutras
doesn’t work this time.


#65

If you haven’t installed the archlinux32-keyring, install it.

There’s an issue with the Manjaro mirrors (not the [manjaro32] repo) that I’m working to diagnose; I think the package database is corrupt but can’t fix it directly.


#66

Which error do you have? I can regenerate the DBs on server-level if needed.


#67

More detail: https://forum.manjaro.org/t/failed-retreiving-file-maximum-file-size-exceeded/35288/6?u=jonathon


#68

I’m currently resetting the x32-unstable repo DBs. Please test it after I’m finished. When OK, simply snap them over to x32-testing.


#69

Resolved for now.


#70

For first when I tryed, the Maximum file size exceeded error was still there. Then I performed pacman -Sw from core, which worked and after that also pacman -S now works as expected. Strange things.


#71

I would like to help contribute to this project if possible. I just learned today that Arch is phasing out 32bit and I need it for older machines. I have plenty of processing power to contribute for builds at the very least.


#72

@SM177Y please contact @jonathon, as he is the project lead for Manjaro32.


#73

If you have spare hardware then ask the good folks at archlinux32 if you can help with their builds first - they have far more packages to build.


#74

First full set of packages:


#75

What a great day already. I downloaded the Manjaro32 xfce 17.1.1 RC2 iso, put it on a USB using etcher, booted it on my Late 2006 MacPro1,1, ie; 32-bit efi only. The install went fine until the grub install failed. I chrooted in, attempted installing grub with another failure indicating the lack of efibootmgr. pacman -Sy to update my DB, installed efibootmgr, re-ran the grub install for i386-efi successfully, ran update-grub, rebooted to a blinking cursor, booted to OS X on other HDD, reinstalled rEFInd and here I am.
So efibootmgr is missing from the live image and will fail but like I said, here I am. I am not sure if the weird boot issue was because of the install failing initially but an updated ISO including appropriate efi packages will give me a chance to test it further.


#76

If manjaro32 is [totally] based on archlinux32… Does it mean that there’s no mhwd and any such customization?
And if not, where are its repos?


#77

archlinux32 is the upstream in the same way as Arch Linux is. manjaro32 still has all of the same Manjaro tooling that Manjaro does. The manjaro32 repos are on the same mirrors as the rest of Manjaro.


#78

Oh, so you still build from the same packages-extra/core etc?


#79

@jonathon I believe the How do I switch branch? instructions on manjaro32.org need altering.

I found that the correct switches are now as follows. using -b is no longer recognised and the api switch for some reason is necessary to trigger the new branch switch -B.

pacman-mirrors -c all -aB {stable,testing,unstable}

EDIT - thanks for updating that Jonathon. I didn’t know -aB could be together as well but that makes sense now so I’ve updated this post accordingly too just in case anyone reads it here first.


#80

2 posts were split to a new topic: Signature from Tyler Dence is marginal trust