Internet says disconnected in KDE even though cable is plugged in and working

kde
#1

I recently installed the KDE edition of Manjaro Linux on my PC. I have it installed on a 500gb hard drive separate from my M.2 SSD so that I can run Linux on my hard drive and Windows 10 on my SSD. I have used Manjaro for about 2 days now and everything has worked great. Today when I went to use my PC, it said that the cable was disconnected even though my ethernet cable is connected and on. No matter what I've tried I can't get it to recognize that my cable is plugged in. When I go over to Windows 10 on my SSD, the internet is fine there but then when I boot back into Manjaro, it still says the cable is disconnected. Any ideas on how I can get my internet back up and work again? I have really enjoyed using Manjaro so far and would really like to get it up and going again. Thanks!

#2

This may very well be a side effect of dual booting with Windows. Windows will sometimes force a complete device shutdown as a power saving "feature". M$ doesn't care if this plays havoc with other OS's. There at least used to be a way to disable this in Windows, but they removed that option quite some time go.

The best way to test for this issue is to power down. Then completely remove all power sources including the battery. Let the computer sit without power for a minute or two. Then press the power button for 20-30 seconds to completely drain all remaining power. Plug your power back in, then boot directly into Manjarro. If your adapter is detected again Windows is causing your issue.

If that doesn't work sometimes resetting the bios to the defaults will cure this issue.

#3

Alright I tried that however both of those things didn't seem to fix it. Any other suggestions?

#4

Have you rebooted your router, tried a different port, tried a different cable.

Did you update just before this happened, a reboot is usually when this occurs after updating.

Please post

hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status" 
inxi -Fxxxz

Does the computer have a working internet connection to post outputs. If not try USB android phone tethering for a temporary connection.

1 Like
#5

I have rebooted my router however I'm sure that's not the problem as the internet works in windows just fine. I updated right when I got it and that's it. The internet seemed to work fine after that.

Outputs for the commands(only was able to get the first one to work the second and third ones just kept freezing the terminal)

16: PCI 1900.0: 0200 Ethernet controller
[Created at pci.386]
Unique ID: fNQ2.SSl7hzwxh+D
Parent ID: rF9W.sArAqRDibeE
SysFS ID: /devices/pci0000:00/0000:00:01.2/0000:15:00.2/0000:16:01.0/0000:19:00.0
SysFS BusID: 0000:19:00.0
Hardware Class: network
Model: "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
Device: pci 0x8168 "RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
SubVendor: pci 0x1462 "Micro-Star International Co., Ltd. [MSI]"
SubDevice: pci 0x7a34
Revision: 0x15
I/O Ports: 0xe000-0xe0ff (rw)
Memory Range: 0xfe504000-0xfe504fff (rw,non-prefetchable)
Memory Range: 0xfe500000-0xfe503fff (rw,non-prefetchable)
IRQ: 10 (no events)
Module Alias: "pci:v000010ECd00008168sv00001462sd00007A34bc02sc00i00"
Driver Info #0:
Driver Status: r8169 is not active
Driver Activation Cmd: "modprobe r8169"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #23 (PCI bridge)

#6

How many Ethernet ports does your system have.

#7

You may have several issue going on here. If you are using the r8168 driver switch to the r8169 kernel module. That can be done easily by going into Manjaro Settings Manager and right cli king on the r8168 driver and selecting remove.

After uninstalling the r8168 driver reboot. The kernel modules should replace the driver after you reboot.

If that still doesn't improve things test some other kernels. Install kernels through Manjaro Settings Manager and always keep at least 2 kernels installed for safety.

Rerun the other commands to see if they still hang after making changes. If they do then it's probably a video driver issue.

Good luck.

#8

I only Have One

#9

Psst, when people give you suggestions it is best to confirm if you have implemented them. I made my suggestions 2 days ago, I would have thought that would have been long enough to test out several fixes that take only a couple of minutes to implement.

Obviously you are in no rush to get this fixed as it took you 20 days to reply to my last post.

You also do not have any understanding of how Linux works. Linux drivers are very different to Windows drivers and they can react very differently with the same hardware. Just because the Windows driver works well with your router and cabling does not mean the the Linux driver will do likewise.

I suggest you either follow the instructions of the people giving you advice or quit wasting the time of people trying to help. My suggestion on testing different cabling is LAN network support 101 standardized advice. Linux drivers may fail on substandard cabling that Windows drivers exhibit no problems with.

Either listen to people's advice and implement it, (and report on its effects in a timely manner) or don't bother soliciting advice. Otherwise, you are simply just wasting people's support time.

Usually if your computer freezes when you input the inxi command that means your video drivers are installed incorrectly. I would suggest you open a separate help thread to resolve that issue. I would also suggest responding a lot quicker than three weeks if you want to get your issue resolved.

#10

Sorry I've been really busy lately and have not had enough time to implement some of the things. I am trying my best to get them done however I do have other things I have to get done too.

1 Like
#11

Also I do realize that I don't have that much of an understanding of Linux and how it works.

#12

I found my way over to the majaro setting manager however I cant find what you mean by right-clicking on the driver. Here is a screenshot of where I am at so far:

#13

MSM -> Hardware -> Network controler

#14

Okay I tried changing the herbal version and it didn’t seem to solve the problem w/ the internet. I still need to try the commands just have been really busy the past weeks. Sorry about that...